Emachine W3107 Digital Media Manage

E-machine / W3107
August 25, 2009 at 20:52:12
Specs: Windows XP
I was going to transfer some pictures from my micro SD card to my computer and for some reason when I inserted it nothing happened... I opened up My Computer and the Icons for the Drives in the Digital Media Manager are all missing and I even tried to restore my icons with tweak UI and went into my Device manager and could not find them there... Now when I start my computer it pops up with new hardware installer that only says Media and its unable to find the drivers for it. I dont know what to do so any suggestions will be greatly appreciated....

Stuck on my emachine

See More: Emachine W3107 Digital Media Manage

Report •

August 25, 2009 at 23:31:15
I Have an eMachine t4010 that did the same thing. The only solution I was able to come up with was going nto Device Manager and remove everything under the USB heading. Once everything is removed, reboot and Windows will reinstall all the USB devices and the appropriate drivers.

Be sure to disconnect all your USB devices first. Remove SD Card, Micro Drive, Printer cable. Reconnect them, or use them one at a time to determine if you have further problems.

It might help if you have your Restore CDs handy. I think Disk 3 (of3) is the one you'll need. There are 4 or 5 USB hubs that will have to be reinstalled, so don't worry if it looks like the same thing is being installed over & over.

Your Card reader and Microdrive Plus other USB Ports& devices each have their own Supporting hardware & software

There is nothing to learn from someone who already agrees with you.

Report •
Related Solutions

Ask Question