DVD not appearing in BIOS

Toshiba / Satellite m45
February 24, 2009 at 08:02:43
Specs: Microsoft Windows XP Home Edition, 1.596 GHz / 1527 MB
I installed a Sony Optiarc DVD RW AD-7590A several months ago in my Toshiba Satellite laptop. It's an IDE drive and has given me no problems since I installed it. Windows was immediately able to see the drive and still can.

The problem I am having is that I can not boot to a cd anymore. I have tried both the manufacturer's system restore disk (which has worked before w/o a problem) and a GParted Live CD that I created and the computer always bypasses them and boots into windows. I have checked the BIOS and the cd-rom drive is the first listed in boot sequence but is not listed under the "Drive I/O" section where the HD is. So, does anyone know why Windows XP would see a drive but the BIOS wouldn't?
I have BIOS version 2.000

See More: DVD not appearing in BIOS

Report •

February 24, 2009 at 16:07:36
If you can't boot from a CD or DVD that is actually bootable (have you tried the disks on other computers?) while booting the computer, that has got nothing to do with whatever operating system you have installed on the hard drive - that's a function of the mboard's bios, only.

"I have checked the BIOS and the cd-rom drive is the first listed in boot sequence but is not listed under the "Drive I/O" section where the HD is."

The CDrom drive does not have to be listed first in the boot sequence, but it must be listed before all hard drives, and/or SCSI.
You being able to select CDrom drive there does not indicate the bios is actually detecting one.
Some bioses do not show any indication they are detecting a CD or DVD drive.

Were you able to boot from a bootable CD in this same DVD drive previously?

In any case, it's extremely unlikely to have anything to do with the specific bios version the mboard has.

Sometimes a CD or DVD may not be detected as bootable if
- the disk is dirty - make sure it's clean
- the laser lens is dirty - try cleaning it off when the tray is ejected with a tissue or a cloth or a Q-tip, or use a laser lens cleaning CD.
- it is a burned disk than was not made in the drive it is being read in - CD-R and DVD-R disks should read fine but other types may not.
- it is a burned disk of a media type (brand, type) your particular model of drive can't read properly

Report •

February 24, 2009 at 23:30:39
Bios look like this? http://www.insanelymac.com/forum/lo...

Try F12 - Boot Menu, select DVD/CD.

Good info in previous post on dirty discs/laser lenses in an ODD.

Just another stupid saying...

Report •

February 25, 2009 at 14:48:10
Thank you both for your quick responses.

It seems to me the problem is that the drive is not being recognized in the BIOS.

I compared my BIOS screen to the one that PC Geek posted and it is the same except for the fact that in the second photo there is both a "Built-in HDD" and a "Built-in ODD" listed whereas I only have the "Built-in HDD". Seeing a screenshot of a similar BIOS confirms my suspicion that mine simply isn't seeing a cd drive to boot from. When I try to boot to the disc manually using the F12 button as recommended it doesn't give me an error but instead thinks for a moment and then boots into Windows.

To clarify my first post I should say that I've never been able to boot to a cd in with this new drive but was with the drive that came with the laptop. I installed the Sony drive as the original Mats---a drive crapped out on me.

So, is there anything I have to do to make the BIOS recognizes the drive?

Report •

Related Solutions

February 25, 2009 at 16:35:52
The DVD drive may have a jumper block for master/slave/cable select (laptop IDE hard drives do I believe; if they don't they're always set to cable select - I know they can be detected as a slave drive on a desktop computer).
If the drive has that, some bioses won't detect the drive properly unless that's set to master or cable select.

If it connects via a cable, one of the wires may be broken or damaged, or the data cable may be separated a bit from the contacts on the connector.
If it connects via plugging into a socket, you could try unplugging it, plugged it back in (with the AC adapter and main battery removed).

On the other hand, since you've never been able to boot from a bootable CD or DVD in when it's in this drive, the feature that detects whether a CD is bootable in the drive itself may have been defective in the first place.

It's extremely unlikely to be because of a bug in the specific bios version, and there is no bios setting I know of that would disable the ODD drive from being detected if it's connected properly, assuming the connection it is on is set to AUTO detect by the method Auto or LBA or similar (obviously your operating system sees it fine).

If the drive has a standard socket/pins the same as an IDE laptop hard drive, it can be connected by means of an inexpensive adapter to a desktop comnputer to see if it's bootable on that - if it ain't, the drive is faulty.

Report •

February 25, 2009 at 22:10:39
Good info from Tubesandwires (over 3300 posts...dude? Wow).

Only info I can add (w/o reading back on the posts) is possibly update BIOS, and/or Firmware on the ODD.

Just another stupid saying...

Report •

February 26, 2009 at 10:22:10
Regarding PC Geek's link and the pictures there...
- make sure the Power up mode is Boot
- if you want the bios to boot from a bootable CD without you having to press F12?, Boot Priority must have CD-ROM before HDD, preferably before LAN
CD-ROM can be after FDD - if you do use the FDD drive that's the best way to set it - in all the older bioses I've tried it in, a bootable floppy is not recognized while booting as bootable if it's listed after the CD drive in the boot order.

- you must SAVE any changes you make before they actually have an effect

- I see your ODD drive connects to secondary IDE by itself, so the drive must be set to cable select or master, either by default or by you.

Apparently your hard drive is IDE too.


Has a 50 pin connector (picture)
So - that is NOT the same as a standard laptop IDE hard drive socket/connector. I don't know if there are inexpensive adapters that would allow you to connect the ODD to a desktop computer like you can do with laptop hard drives.
Writes to DVD±R media at 8x, so it doesn't use UDMA 66, which might have been a problem on an older laptop such as yours.

Sony specs
Default drive ID setting: CSEL (cable select)

Firmware upgrade:
A last resort.
Flashing is always risky!

31-08-2008 Bob
I just noticed in a newegg review this drive ships set to master

next post r_saotome
I'm using a Clevo 901C....
...the drive itself was set to master
In my older Dell XPS (gen1) notebook, the HD is IDE, and the optical drive is set to SLAVE

If the laptop ODD is set to cable select and that can't be changed, the bios may see it as master (or slave), but the drive itself isn't set that way.

If the ODD is set to cable select, either because that can't be changed or via a jumper or other method, whether the computer sees it as master or slave doesn't depend on the drive itself - it depends on whether what it connects to has one drive connection or two on the same IDE channel - if it has one drive connection on the channel, it can only be seen as master - if it has two, it can be seen as master or slave.
On a desktop computer, you can connect any IDE drive to either of the two drive connectors on the same 3 connector IDE data cable - if it's set to cable select and on the end connector the drive is seen as master; if it's set to cable select and on the middle connector it's seen as slave.
Two drives on the same cable/channel must both use cable select, or master/slave jumpering (one of each type; in which case the connector the drive uses doesn't matter).
On a laptop, there may be no physical cable with 3 connectors on it connecting to one IDE channel - but it's wired up the same way as if it did have that - the only way available an ODD set to cable select may be detected if the laptop has only one IDE channel, and an IDE hard drive, is as Slave.

Older laptops or newer laptops with a SATA controller may have only one IDE channel you connect one or up to two IDE drives to, but apparently yours has two IDE channels.

Somehow he was able to have the drive seen as slave on the older laptop, either because the ODD is set to cable select and so was the hard drive, and the ODD can't be set to anything else and is automatically seen as slave when connected to the middle connector on a 3 connector data cable (or the laptop wiring equivalent of that), or there was a jumper or other way of setting slave on the 0DD drive itself (and the same on the hard drive was set to master).

How to take apart Toshiba Satellite M45 laptop yourself.
You could make sure it's connected properly.
e.g. check for bent pins, a broken or damaged wire to what it plugs into

Report •

Ask Question