Doesn't stay on with CPU and GPU plugged in

May 12, 2009 at 19:10:51
Specs: Windows Vista SP1
My home-built computer will now no longer stay on after a few seconds when both the CPU and GPU are plugged in. I built it a few weeks ago and it's been fine until now. I opened the case today to make sure the graphics card was installed correctly and when I put it all back together, this happened.

Here are my specs:
585W Power Supply
Intel Core 2 Duo 2.8GHz CPU
XFX nVidia 9800 GT GPU
4 GB RAM


See More: Doesnt stay on with CPU and GPU plugged in

Report •


#1
May 12, 2009 at 19:24:15
Can you give more details on the psu-brand ? amps on the +12v rail(or rails) ?

Report •

#2
May 12, 2009 at 19:25:55
It is Orion Brand. 19A on +12V1. 20A on +12V2

Report •

#3
May 12, 2009 at 19:35:26
So when the video card is NOT plugged in the computer does not shut down after a few seconds ? Do you have another video card you could try or onboard video just to see if that's part of the cause ?

Report •

Related Solutions

#4
May 12, 2009 at 19:39:33
Right, when it's not on the board, then it does not shut down. Likewise, if the card is on the board and plugged in, and the CPU is unplugged, it also stays on. I do not have onboard video or another card.

Report •

#5
May 12, 2009 at 19:59:31
Someone else may have a different opinion, but it sounds like a psu problem to me.

Report •

#6
May 12, 2009 at 21:28:38
What kind of PSU problem?

Report •

#7
May 12, 2009 at 22:35:45
"It is Orion Brand"

You get what you pay for....


Report •

#8
May 12, 2009 at 23:15:50
So I should go get my money back then?

Report •


Ask Question