Disappearing CD Rom Dell Dimension 2400

Samsung / Sw-252s
December 8, 2009 at 09:23:34
Specs: Windows XP Pro Sp3
After computer on for a few hours I lose access to CD Rom draw won't open. Does not show up in My Computer of Windows explorer. Does not show up in Hardware device Manager.

Restart computer and all fine.

Don't know how to get to bios setting without restart and restarting fixes temporarily the issue so can't tell if lost on BIOS at that time too.

See More: Disappearing CD Rom Dell Dimension 2400

Report •

December 8, 2009 at 09:33:20
If the tray won't open by pushing the buttons on the drive itself then that isn't a Windows issue.

I would guess your power supply may be failing.

Report •

December 8, 2009 at 10:25:55
I had thought of that but wasn't sure.

Are there any other symptoms I may want to look for in this regards. The computer is 5 years old.

Are there any tests a simpleton computer user like me can do. I know how to remove a PSU and put one in just not familiar how to test one.

The one they have in there I think is a 200-Watt Non-PFC Power Supply Not sure what PFC means


Report •

December 8, 2009 at 18:11:19
PFC---Power factor correction. It's not a spec that matters as far as your computer hardware is concerned.

Might be PSU problem but if the voltage dropped enough on on the cdrom's 5 or 12 v connections it should also affect the hard drive and maybe the motherboard--that is you'd be experiencing other problems too.

So maybe it's the cdrom which for some reason needs to be reset occasionally, which a restart would do. Still, I've never run across that problem either.

How long has it been doing this and did anything change prior to the problem starting?

Onward to 300

Report •

Related Solutions

December 8, 2009 at 19:06:23
I don't use the cd that much so I just put up with it. Probably been a year that I first noticed it. But I think I know why I hadn't noticed it before then....

What has changed is the way I run the computer.

Used to be I would turn it off when I walked away for awhile then restart it when I needed it later in the day. Now I just leave it on from 5am till about midnight. So I really don't know how long the issue has been there because before I was always restarting the machine.

I tried googling and also went to Dell forums but can't find anything like this problem.

Report •

December 8, 2009 at 19:15:26
How do you try to open the tray on the drive? With the buttons or through Windows?

Report •

December 8, 2009 at 19:29:24
I press the button to open the tray but it won't respond then I go looking for it in My Computer or Windows Explorer and it is no longer listed there.

Seems to happen after computer on for a few hours. Is there any trouble shooting techniques I can use to narrow this down? I was thinking of turning the computer on and every 30 minutes check to see if the problem appears but darn that is so archaic and rather crude way to troubleshoot Grin.

I have been trying to think what in the unit could cause it to suddenly get lost and no longer sensed in the Operating System.

Report •

December 8, 2009 at 20:13:21
I think it's the cdrom that's shutting down first. Then the OS removes it when it can't find it.

Can the bios or OS shut down a cdrom the way it can a hard drive? Never heard of that happening before but if so maybe it can't restart it.

Do you know if the hard drive and cdrom are on the same cable?

Onward to 300

Report •

Ask Question