Delayed write failed - After a defrag of exte

June 4, 2010 at 08:18:14
Specs: Windows Vista, XP, core2 DUO Quad
Okay I have windows XP 64 bit OS. I have an external USB drive that has worked perfectly until about an hour ago. Here is how the issue began.

I used the disk tools you get to in Windows XP by right clicking your C Drive and choosing properties / tools.

I ran the defragment now.

I chose to defrag my external drive for the first time. During this I got a Delayed write failed error. This stopped the defrag process. At this time I could go onto the drive and see all the folders but most were empty. Any files I saw listed could not be opened.

Things I did to hopefully solve this that didn't work:

1. restart computer - Does nothing same problem
2. Turn off the drive and back on. - Does nothing same problem
3. Turned off PC and plugged usb drive cable into another usb port. - Did nothing but now i can't even see anything on the drive at all. No folders and no files!

Not sure what do do next.

Any help is appreciated.

See More: Delayed write failed - After a defrag of exte

Report •

June 4, 2010 at 09:22:10
Does the external drive show in Disk Management? If so, post what info you see for it.

Report •

June 4, 2010 at 13:41:56
Okay, here is what is going on.

I have this external USB hard drive that I have used flawlessly for 1 year on a windows XP computer system. After a while files will normally become fragmented on a hard drive so it is a good idea to defrag the drive occasionally. I went to defrag this hard drive "which worked perfectly up until this defrag" and that is when the "Delayed write failed " error came up. SInce then it won't work at all with the Windows XP Machine.

To test something out I took the drive and plugged it into my Windows VIsta Desktop and it found the drive. Sometimes I can access the files other times i have to turn the drive off and back on to be able to access files. Other files can't be copeid off it like a video I have on there but strangly enough it will play in windows media player off the hard drive itself?

To test it even further i took the drive and hooked it up to my windows XP laptop. THis is the third PC i have in the tests. It showed it in my computer but no folders or files listed at all.

SO far the only system it is working on somewhat is VISTA.

REMEMBER IT WAS WORKING FINE ON THE ORIGINAL WINDOWS XP DESKTOP UNTIL I DEFRAGGED IT. Dueing the defrag it got the Delayed write failed erro and since then it won't work at all with XP. I have tested it on two separte windows xp computers and nothing. Vista is the only one it somewhat works on. SO what is the issue?

What coudl be the problem?


Report •

June 4, 2010 at 15:05:10
I asked you a simple question and you just elaborated on your original post.

What do you see in Disk Management.

Go to Control Panel> Administrative Tools> Computer Management> Disk Management.

See if your external drive is listed there and what information is listed about it.

Report •

Related Solutions

June 4, 2010 at 15:49:32
Okay, in XP of course it shows Unkown. But in vista it is there and it is healthy.

BTW not that it matters but I am a computer professional and a software developer so I do understand a PC but I am tryign to figure out if the drive is bad or not. If it is a bad drive why did it quit working after a defrag on XP but work on VIsta now? This makes no sense. This is why i posted on this forum to see what anyone else though about this. As i said before it wasn't until a DEFRAG that things went wrong with it. Before that never had a issue at all.

BTW thanks for the replies.

Report •

June 4, 2010 at 16:43:53
Well, defraging can stress a drive.

Is it possible you interrupted the defrag?

How much available space was left on the drive before the defrag?

Does the full capacity show in XP & Vista?

Report •

Ask Question