CrashFree BIOS Help

Custom
September 15, 2007 at 06:53:32
Specs: Win Vista, P4 2.53GHZ/ 512 MB RAM

Hello, I need help with this problem that's been bugging me for a day now. Stupid me, I decided to flash my computer's BIOS from Windows (yeah, I know bad desicion) and when I restarted the computer....nothing, just a blank screen, no POST, no beeps.

Obviously, the Bios is corrupted. HOWEVER, I do have an ASUS P4PE motherboard that supposedly has something called CrashFree BIOS (version 1) that says in the event that your BIOS does become corrupted, this feature will read a BIOS file off of your disk drive and install the bios from that disk, assuming you have the right files on it. I'm assuming that this is like a read-only BIOS recovery tool, soit's not ruined itself.

Here's what I did. I put the BIOS I wanted on a disk, named it P4PE.rom and threw it's original p4pe1002.awd file on there as well. I also put aflash.exe and awdflash.exe on there to install it. I read somewhere that you had to take your video card out to do this, so I did that because absolutely nothing happens when you leave it in there.

What resulted when I turned on the computer was a long beep, then the floppy disk's light came on and was reading my disk 30 seconds-1 minute, then stopped. Then I pressed a key on my keyboard, which made the disk drive's light come on again.

Obviously since it responded to the keyboard, and was reading my disk, it's not dead yet, something has to be present in order for those to work. My hypothesis is that I'm missing a file on the recovery disk and the CrashFree BIOS can't perfrom without this file, because when I put everything back in, there's still nothing.
Do I need to put DOS or something on there?
Have I stumbled into the CrashFree BIOS, or the Twillight Zone? Replacing the BIOS chip would be my last resort, the CrashFree BIOS seems to be almost working here. Any help would be appreciated!


See More: CrashFree BIOS Help

Report •


#1
September 15, 2007 at 07:11:20

Do you have the manual or some sort of online help files for the ASUS P4PE motherboard ? If yes, is the procedure you followed what they recommend ?

Report •

#2
September 15, 2007 at 07:27:19

Thanks for the quick follow-up!

Anyway, I don't have the written manual, as I'm not the original owner of this machine.

I did however find a snippet from the manual, which was posted online, here's all that it says:

CrashFree BIOS
This feature allows you to restore the original BIOS data from a floppy disk in cases when the BIOS codes and data are corrupted. This protection eliminates the need to buy a replacement ROM chip.

That's it. The manual keeps kind of mum on what to do, so I'm trying to see if anyone has any experience with this.

I got some of the procedure from here:
http://www.abxzone.com/forums/archi...

But most of it to no avail.


Report •

#3
September 15, 2007 at 07:38:16

You can download the whole manual here:
http://support.asus.com/download/do...

Report •

Related Solutions

#4
September 15, 2007 at 07:51:10

Thanks anyway, but the manual just said the exact same thing I posted before. I'll try a few more things with it, see what happens.

Report •

#5
September 15, 2007 at 08:11:38

After you flashed the BIOS did you immediately enter the BIOS screens and reset values? Did you save the old BIOS file?

Report •

#6
September 15, 2007 at 08:23:30

No, it just restarted and nothing came up on screen. I didn't save the old bios, but I do have a downloaded BIOS file that I'm trying to install, but aren't wroking, even though the disk drive is reading something........

Report •

#7
September 15, 2007 at 10:48:55

how can it read a disk drive without a bios to detect a disk drive?

larry


Report •

#8
September 15, 2007 at 11:03:02

Do you have onboard video and add in video cards?

Report •

#9
September 15, 2007 at 11:06:08

It can read the disk drive because it has a recovery bios in case this happens, that is hard-wired to read the disk drive for a recovery disk with a flashable bios. That's what I'm trying to get into, and it appears to work in that respect.

No, the video card is a PCI one, it can be easily removed and reattached.


Report •

#10
September 15, 2007 at 11:50:37

Try making the floppy diskette bootable.

Report •

#11
September 15, 2007 at 12:00:23

what does the DOS command "/s" do? Whenever I type /s into the keyboard, the disk light comes on again. Keep in mind that I don't have any view of what's happening, since I had to take out the video card in order for the floppy drive to work.

I made the disk with a BIOS bookdisk, should I change it to a Windows 98 bootdisk?

One thing that's comforting me here is that it's not dead, since it's responding to the keyboard and the disk drive.


Report •

#12
September 15, 2007 at 12:17:23

Some mboards have a jumper that must be in the right position when you flash your bios.
If you flash with it in the wrong position, your flash will fail, and in some cases you can end up with an empty bios.
Check your mboard manual to see if you have such a jumper!!

You are taking a big risk when you flash your bios - if the flash fails, and/or the flash chip physically fails while flashing (this is COMMON - these cheap flash chips can only be flashed an unpredictable small number of times), you will have a mboard that will not boot.

If you see messages like this or similar, especially including one with boot block in it:

"award bootblock bios v1.0"
"detecting floppy drive a... fail"

You can't get into the bios Setup because that part of the bios is corrupted, or the wrong version, or not there at all. The boot block portion of the bios is still there and is automatically looking for a floppy with the proper files on it, and isn't finding one.

See response 2 and 7 in this:
http://www.computing.net/hardware/w...

If you see no messages at all, the flash chip may have physically failed.

If that's the case the Crash free bios routine won't work even if you do it the right way - you have to replace the flash chip - easy to do if it's in a socket - not worth the expense if it is soldedred to the mboard.

There should be info about how to do the crash free bios routine right on the Asus web sites somewhere - the global one? - if it isn't specified well enough in the manual, and/or there may be instructions on the CD that came with the mboard.

Or you could use the standard Award procedure in the second post at your link in response 2 - HOWEVER - make sure you have the right bios update file, and use the Award flash utility and the line for that in Autoxec.bat.

It's well known Aflash often will not work for that purpose.
You MAY be able to use Aflash instead of Awdlash if it has the right command line switches.
type: aflash /? (press enter) (or whatever it's exact file name is) where aflash is located to see it's switches.(a space before /?)
Type awdflash /? (press enter) (or whatever it's exact file name is) where awdflash is located to see it's switches.(a space before /?)

You may need to go to a command prompt to display that and not have it immediately disappear. E.g. Start - Run - type: cmd (Enter) type: a: (Enter) type: awdflash /? (Enter) (a space before /?).

You must be able to do the same things the required awdflash switches at the second post in your link in response 2 do with Aflash in order for it to work.

There are many Award Flash utility versions. If you use the wrong one (or use a bios update of the wrong size), you will get error messages (if you had video) and it won't flash the bios. If there is an Award flash utility available on the same page as where you got the bios update, or if it's included in the bios update download, that's the right version. If not, you need to get a version that was available about the same time your mboard first came out.



Report •

#13
September 15, 2007 at 12:23:24

Well, I just typed in the command:

AFUDOS /ip4pe.ROM /pbnc

into the keyboard, and the disk drive was hard at work reading/writing something. Obviously DOS commands work (dir, /s), so now I'll take a look if I can put the video back and get into the BIOS, if it did just write it. Thanks everyone, we're almost there!



Report •

#14
September 15, 2007 at 12:23:58

The /S is a DOS command 'option' but not a DOS command.

I can't see any way you can get anything done without a monitor. I wonder if the video card is defective and keeping the motherboard from working. Can you borrow another card?


Report •

#15
September 15, 2007 at 12:36:48

If I really wanted to, I could take the Geforce 2 out of the Family computer, I just don't want to fry that either.

Yeah the video card for some reason prevents the system from booting up. Strange, everything else works fine on this computer. Based on what I've read, and the beeps I've heard out of the box, the CrashFree menu is coming up and then reading the disk. After reading the disk, it seems to throw it into an A:/ prompt. Weirdest thing I've ever seen while repairing computers.

I'll try and reset the video card if I can, although it confuses me (and irritates me) as to why it prevents the CrashFree menu from coming up.


Report •

#16
September 15, 2007 at 12:58:57

Great news everyone!
I pulled the Geforce out of the other desktop, and I've got video now! Also I put the video card from this computer in the other computer, and that video card is now working with that computer!

I'll let you know of any further details, right now I'm overjoyed!


Report •

#17
September 15, 2007 at 13:11:31

If you can't find the correct procedure on the Asus web sites.....

On a working computer

With the floppy afudos is on in a in a drive
type: afudos /? (press enter) to see it's switches and syntax.(a space before /?)

You may need to go to a command prompt to display that and not have it immediately disappear. E.g. Start - Run - type: cmd (Enter) type: a: (Enter) type: afudos /? (Enter) (a space before /?).

You need switches that do the same things the AWDflash utility does in the second post at that link of yours in respone 2.

E.g. you may need / before every switch, and spaces beween each switch .
DO NOT use the switch for flashing the boot block!

......

If that doesn't help....

Waddaminit.

An update file with a .rom extension usually indicates it's an AMI update. Apparently Aflash can flash both Award and AMI bioses, but you don't need a flash utility at all to recover an AMI bios, at least you don't with older AMI bioses.
But you need to rename the update file to AMIBOOT.ROM

"AMI: The AMI boot-block BIOS will look for a AMIBOOT.ROM file on a diskette. Copy and rename the correct BIOS file on the floppy and power up the PC. The floppy doesn't need to be bootable. You will see the PC read the floppy, after about 4 minutes you will hear 4 beeps, this means the transfer is done."

It's worth a try.


Report •

#18
September 15, 2007 at 13:16:40

YES! It worked! The BIOS was successfully flashed, The BIOS came up, now Windows Vista just loaded up! I'm so happy! I won't make the mistake of flashing from Windows again, what a nightmare!

I want to send out a large thanks to everyone who kindly helped me out of this predicament. Without you, I probably would have given up on this computer for dead, but now it's alive!


Report •

#19
September 15, 2007 at 14:18:10

Now the question. Why did you flash the BIOS in the first place?

Report •

#20
September 15, 2007 at 14:58:16

Ah, that question. Well I was trying to overclock my system a bit, to accomodate more intense gaming. With the new BIOS, there was a turbo mode, which automatically set the overclocking values for you, without any guesswork as to what was stable and what not. Again, not knowing a darned thing about the system (I'm not the original owner, I got it when someone was throwing it away), I assumed flashing from windows was safe. Boy was I wrong! There's a little background history for you.

Report •

#21
September 15, 2007 at 16:50:31

"With the new BIOS, there was a turbo mode, which automatically set the overclocking values for you, without any guesswork"

There is no "one-click solution" when it comes to overclocking. The CPU, RAM, graphics, etc settings should be addressed individually to attain max stable performance. "Turbo mode" is no substitution for good ol' fashioned trial & error.

"I was trying to overclock my system a bit, to accomodate more intense gaming"

You're running Vista with only 512MB RAM, not to mention you have an old 133MHz (533MHz FSB) P4. No amount of overclocking is gonna improve gaming performance...you need hardware upgrades!


Report •

#22
September 15, 2007 at 19:07:21

Yeah I really need to throw another 512 or 1 Gig stick in there to get it where I want it to be. Then a 3.4 Pentium 4 with HT, that's the highest I can go on this board since it's a socket 478. Great technology for 2002, quickly fading away in 2007, and I got this thing in 2007! Hey, it was free!

Anyway, I'm going to overclock it to 2.85GHZ with 150mhz external frquency and 400mhz for the RAM. That's where I was before I got greedy with the speed. It was stable at that point, it showed a slightly faster bootup time for Vista.

If you think that's old, for a good portion of last year, I used an old Gateway 2000 that was overclocked to 200mhz from 166mhz, with only 64mb of RAM! Now isn't that fun trying to play videos on.......oh yeah, it wouldn't even play videos. Man that thing was attrocious.


Report •

#23
September 15, 2007 at 19:17:44

"YES! It worked!"

That's good to hear, but what are the details of what you did to accomplish that?
Without that informationn this thread is of no use to anyone with the same problem in the future.


Report •

#24
September 15, 2007 at 20:27:29

Ok, here's a detailed write-up on what I did to fix this, after my originla post (I know this problem persists many P4PE users, as I have read yesterday and today).

1. Remove Graphics Card (mine was an ATi Radeon 9600, whether or not the grahics card works depends case to case)

2. Make BIOS bootdisk. You can make a floppy disk or a burned CD, it doesn't matter which one. Include your bios file, named p4pe.rom and the aflash.exe utility. Also install the BIOS bootdisk from bootdisk.com, it's not hard to find.

3. Borrow PCI video card from other desktop computer. In my case, I took an old Geforce 2 out of our old Dell, put it in this desktop, and put the Radeon in the Dell to test if it worked.

4.Place your BIOS bootdisk that we made in step 2 inside the dekstop before turning on the power.

5. Boot up your system. You should see the recovery BIOS working and saying Bad Bios checksum or something like that. Here's a link to some pictures of what it will say:
http://www.asus.com/999/html/events...

6.When we get to an A:/ prompt, run your aflash.exe. In aflash, select choice 2, write bios without ESCD and something else.

7. Here you may be given a few prompts to confirm that you want to erase the current BIOS and replace it with the one on your disk. Answer yes to all of them, even if they say that the Bios isn't made by Asus (you know it is already).

8. Now you must wait for aflash to write the Bios. When it is done successfully, exit to the A:/ prompt and pull the plug on your computer.

9. Boot your computer back up. Your computer should reach the Bios, which you'll have to reset the time and the like, and then it should boot into Windows or your OS.

10. If all of the earlier steps were successful, put your video card back in your machine, and put the borrowed video card from step 3 back in it's computer.

11. Your computer should now be back to normal, and your wallet should be happy now that it doesn't have to pay for a new Bios chip.

There you go! One of the best CrashFree Bios version 1 explanations on the net right now. Most people seemed to give up because of the video card issue, and bought a new Bios chip or motherboard, that's why there aren't many helpful resources like this on the internet.


Report •

#25
September 16, 2007 at 07:46:03

Well thanks for that!
Too often we don't get an explanation of what worked, making the thread useless to others, and our answers wasted effort.

Some things stay the same - in order to get video, sometimes you must remove an AGP video card and use a PCI one, or on older mbords with ISA slots, remove an AGP card or a PCI card and use a PCI one or an ISA one.

Question - please answer - did you have to rename whatever the update filename was to p4pe.rom ??

If you did, then AMI bioses still require a specific name, though it may now be specific to your mboard model.

Question - please answer -
"Also install the BIOS bootdisk from bootdisk.com, it's not hard to find."

What did you mean by that?
Or did you mean to say "OR install the BIOS bootdisk from bootdisk.com, it's not hard to find."
Usually having a bootable floppy of whatever operating system (it doesn't matter which one) with the flash utility and a bios update on it, and possibly an autoexec.bat file with a specific line in, and/or having the update file named to a specific name, is all you need.


Some things are different.
Bioses have gotten larger as time has gone by.
Smaller bioses didn't have the room for more sophisticated code, so the bios designers came up with the boot block bios idea, and AMI came up with the autoflash idea using a specific name you had to rename the update to. I expected you would see some sort of boot block bios message if you saw anything at all when you have video.
The code in a boot block bios, at least in older bioses, is minimal and only recognizes a floppy disk and you often get only error messages if you do see video - being able to also recognize a bootable CD is something I wasn't aware modern bioses could do - but you could use the recovery procedure specific to your bios brand even if you didn't have video. It sounds like there is now a lot more code in the boot block.
Now that the bioses are larger they have the room for more sophisticated bios recovery methods.
........

Comments:
Whether you run Aflash or any flash utility manually like you did or run it automatically by using command line switches, normally you should NEVER flash the boot block - it almost always doesn't change for a particular mboard model, and it is a emergency backup that is there so that even if you use the wrong bios update or something goes wrong during a normal flash procedure or a recovery flash procedure, you will be able to use a recovery procedure to flash your bios again. If you have the wrong bios update and aren't aware of that, or if something goes wrong during the flash procedure, if the boot block potion of the bios update you use is different, your mboard will not probably boot after the flash and you will definately have to get a new flash chip, already flashed before you install it.
So you shouldn't answer YES to flashing the boot block if you use the flash utility to flash manually, or use a command line switch to flash the boot block.
Once you have a working bios, THEN you have the option of also re-flashing the boot block, with less risk because you then know it probably must be the right one since the rest - the majority of the bios code - of the bios update works with your mboard model and with the existing boot block, but personally I wouldn't risk it just to flash the boot block too.
...

"My hypothesis is that I'm missing a file on the recovery disk and the CrashFree BIOS can't perfrom without this file, ..."

According to the information I've seen, recovering the bios cannot depend on external files - you have to be able to recover the bios regardless of whether you even have a hard drive with an operating system on it. The ability to recover the bios has to be built into the boot block portion of the bios, and the boot block must be there and be the proper version, specific to the I/O chip on your mboard and often specific to other chips on the mboard, often the ones in the main chipset - different mboard versions or revisions of the same model may have different I/O chips even if every other chip on the mboard is the same. Older boot blocks cannot recognize anything except the proper files on a floppy. The abilty of yours to recognize a bootable CD is a bonus, especially for recent systems that don't come with a floppy drive, though the mboard usually has the header for one and I've never seen a bios that doesn't have the support for a floppy drive.


Report •

#26
September 16, 2007 at 08:17:27

Answer to question 1:

Yes you had to rename the BIOS file to p4pe.rom. The file was named at first, p4pe1002.awd, but then I renamed it to p4pe.rom. This goes for any Asus motherboards that have the CrashFree Bios (possibly more). Say you have an Asus p4800 motherboard, you'd then name the Bios file that you're trying to flash, p4800.rom

Answer to question 2:

The BIOS bootdisk from bootdisk.com MUST be on the same floppy disk or CD as Aflash.exe and P4pe.rom (Bios file). The BIOS bootdisk makes your disk bootable, and takes up little room, so that you can use aflash.exe at the A:\ prompt generated by the BIOS bootdisk, to flash your BIOS.

I hope this becomes a valuable resource for people wishing to solve this problem, as it was agonizing for me to piece together.


Report •

#27
September 16, 2007 at 08:40:16

Thanks for those answers.

I think it's more likely you must rename the bios update file if it has an AMI bios on the mboard - Award bioses use different rules, at least they have up until recently as far as I know. You would have to look at simlar infor for an asus mboard with an Award bios version to know for sure.

I don't think your would need to specifically have the bios boot disk - as long as the floppy disk is botable it should work.


Report •

#28
December 31, 2007 at 15:17:36

I have 100% the same problem (but mine is on an Asus Commando mobo) and none of the above worked for me. I tried no video card and I still get no response from the system. No luck with a pci card either.


Report •


Ask Question