Articles

COM1 does not initialize in Windows

August 16, 2005 at 10:59:18
Specs: WIN 95, 144 MB RAM

The system is old, but I cannot upgrade because of proprietary software doing data acq and control. I had been using the single COM1 port to get data in via RS232 and tried installing a PCI serial port card. Boy was that a mistake. I could not get the virtual port (COM5) to work and now the COM1 port does not work, at least not in Windows. DOS based diagnostics (like COMSHOW) see the COM1 port and let me get data in and out, but programs like Hyperterminal, Commsniffer, Windmill, and Datascope jsut give me error messages.
It is not anything simple like baud rate or anything I can change in Device Manager. That serial port card left junk in the registry, I removed it, which didn't solve the problem. The BIOS on this Dell system does not seem to be very useful either.
Does Windows initialize the com ports or look for info on them somewhere where I have not looked yet?
Thanks in advance for any help!

See More: COM1 does not initialize in Windows

Report •


#1
August 16, 2005 at 12:30:00

Remove it from device manager. Also remove any com ports there you may have manually created. On next boot up windows should refind and configure it. If it doesn't do it automatically, do an 'add new hardware' from control panel.

Report •

#2
August 16, 2005 at 12:39:17

Thanks Daveincaps, I tried that (actually I had tried remove and refresh in Device Manager already) but that did not fix the problem.

Report •

#3
August 16, 2005 at 13:16:00

Yeah, it probably the registry or maybe the card you installed changed the com drivers. What does it show in 'driver file details' for the com port in device manager?

Report •

Related Solutions

#4
August 16, 2005 at 14:14:26

You cannot tell from device manager that anything is wrong. The driver files are serialui.dll and serial.vxd, both are in the windows/system folder. The last one is a virtual device driver last modified 3/28/2002. Maybe I will go to driverguide and see if the driver got messed up. Something else that is weird, I have set it to 9600 baud (which is also somewhere in the config files) but when I run msd.exe it says that it is set at 2400 baud.

Report •

#5
August 16, 2005 at 14:45:23

I think MSD can only show up to 2400. That's the way it is on mine too.

The file names look OK. Mine (98 SE) also had vcomm.vxd as a part of vmm32.vxd. Vmm32.vxd is a file that's created when windows is first installed and I don't think it gets modified. If it's gone you'll get an error message about needing to reinstall windows. So your file is probably OK.

One thing to consider would be to run regedit and delete the Enum key in Hkey_Local_Machine. That removes all the hardware settings so on next bootup windows sets up the hardware as if it was an initial installation. You'd need to have any drivers not on the 95 cd, such as a modem for example. Also, before doing that, you should create a folder on the HD named something like 'Win95' and copy the contents of the win95 folder on the installation cd into the HD folder. That way if windows doesn't initially see the cdrom you can direct it to search the win95 folder on the HD for the drivers it needs.

But it may be best to wait on that for others to post in. They may have a better idea.



Report •

#6
August 17, 2005 at 13:34:25

OK one deleted registry key and about 10 reboots later it is the same thing. I note that in device manager it seems to think I have a serial port mouse installed when it automatically configures. As long as that "serial mouse" is there the com port will not work at all. So I removed it and I am back to the COM port working in DOS but not in windows.
I hunted around the net and basically have decided that something else is trying to access that com port or the driver is corrupted. There are not that many processes running...nd the driver size seems to be off, it is 13 kB dated 3/28/02 instead of 18.6 kB dated 8/24/96. I wonder if that stupid card swapped out the drivers on me. Device manager also does not recognize where my serial.vxd came from.
Anyway thanks for your help, this has been very entertaining :)

Report •

#7
August 17, 2005 at 18:41:02

You're welcome. I can email you the two files--serialui.dll and serial.vxd--if you like. They're from 98 FE but should work with 95. And I know they haven't been modified.

Post back an email address if you want them.

You can also extract the files from your 95 cd. The command would be:

EXTRACT /A D:\WIN95\WIN95_02.CAB SERIAL.VXD /L C:\WINDOWS\SYSTEM

from the windows run line or dos prompt, where D: is the cdrom drive letter. And that's all in one line with a space between .CAB and SERIAL.

Replace SERIAL.VXD with SERIALUI.DLL to extract the second file.


Report •

#8
August 18, 2005 at 07:14:44

Hi Daveincaps,
I sent you my email addy in a PM since I do not want to post it here. I have WIN 98 SE so maybe I could use serial.vxd from there? Anyway of course I do not have WIN 95 diskettes (yet). This was a DELL OEM sold with a machine that requires control and daq which I got used so not too much came with it. Thanks again for your help.


Report •

#9
August 18, 2005 at 13:59:17

I just sent the files. I would think that either both 98 FE and SE would work or neither would work.

It's also possible you have the 95 cab files on your drive already. Check in C:\WINDOWS\OPTIONS\CABS and also see if there's a C:\WIN95 folder.


Report •

#10
August 18, 2005 at 17:25:26

Daveincaps, you rock, thanks for the files. I was really hoping that would solve the problem since the serial.vxd file was obviously wrong. Drats, it didn't. Now I am back to hunting around in the registry or trying to figure out if there is something runningin the background that is trying to get at my COM1 port. Thanks again, I'll have at it again tomorrow...

Report •

#11
August 18, 2005 at 21:26:16

Thanks. Maybe you'll be able to figure it out.

If you have the cab files on your hard drive you could try a over-the-top reinstallation. You wouldn't lose any of your software. You'd need to rename the win.com file in the windows directory to something else and then start the installation. When it asks what directory to install windows in, change it from the default of 'windows.000' back to 'windows' so that everything installs in your original directory.


Report •


Ask Question