Cibox 19-inch LCD monitor changes from its native state

September 25, 2012 at 09:54:28
Specs: Windows 7, AMD 255 3.1GHz Dual, 4GB Kingston 1600MHz
My main display (19" LCD CIBOX) keeps reverting from generic Non-PnP Monitor to its proper model name in the screen-resolution window. Each time it does this it plays the 'found new hardware' noise, but with no accompanying message box. I have contacted Cibox for drivers, with no response. Win7 tells me that what it is displaying is 1440x900, when it clearly isn't. Any help much appreciated.

See More: Cibox 19-inch LCD monitor changes from its native state

Report •

September 25, 2012 at 13:57:31
You don't need monitor drivers. You probably need to update your graphics drivers. Post your current graphics card/chip.

If you have a pre-built computer and have not added in a graphics card then post the brand an complete model of the computer.

Report •

September 26, 2012 at 15:44:12
I hand-built it from scratch; Nvidia GeForce GT 430, 2GB version. I do currently have the latest drivers. Unfortunately now that I have played with the settings for a bit, the problem has changed: Now the DVI socket from my graphics card is making the output from them monitor flicker. At first I thought it was the power cable due to the fluctuations, but from switching my monitors around I found it was the socket. I have a DVI to VGA converter there for my monitor, would it be the converter or the graphics card? Thanks again, much appreciated.

Report •

Related Solutions

Ask Question