cd-rom dvd-rom

Hewlett-packard Pavilion a720n desktop
February 26, 2010 at 14:29:23
Specs: Windows XP
both devices only light up for a few minutes after inserting a disk, nothing pops up on the screen --- they are not even listed as drives.

Just started happening when I moved (very carefully) my cpu.

See More: cd-rom dvd-rom

Report •

February 26, 2010 at 14:53:54
"Just started happening when I moved (very carefully) my cpu."

It's just a computer case, or case !

The cpu = central processing unit , or processor, or microprocessor, is inside the computer case, is installed in a cpu or processor socket on the motherboard or mainboard, and is the most complicted integrated circuit chip on the computer.

Unplug the case/power supply, or switch off the AC power to it otherwise.
Power off your monitor.
Open up the case by removing the left side panel as seen when you're looking at the front of the case.
Check all the connections of the wiring to make sure they are all the way onto their pins and into their sockets, especially the main connector from the power supply. The wires close to the mboard going into the main power connector/socket should be more or less perpendicular to the mboard surface rather than at an angle. Make sure all cards in slots are all the way down in their slots.

A common thing that can happen with ram, even ram that worked fine previously, is the ram has, or has developed, a poor connection in it's slot(s).
This usually happens a long time after the ram was installed, but it can happen with new ram, or after moving the computer case from one place to another, and I've had even new modules that needed to have their contacts cleaned.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

For a brand name computer, see the Owner's or User's manual if you need to - how to remove or replace the ram is usually in that - it may already be in your installed programs. If you can't get into Windows, it may be on a disk that came with the computer, or you can go online and look at it or download it - it's in the downloads for your specific model.

For a generic desktop computer, see the mboard manual if you need to - how to remove or replace the ram is usually in that.

If you fiddling with the drive's data cables, or in any case...

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

While you're in there, if the cpu fan/heatsink has mung (dust, lint, etc.) on it, clean it off, but DO NOT use a vaccuum cleaner to do that (they produce a tremendous amount of static electricity when running, and anything connected to them can discharge that to your components) - use canned air, or an air nozzle if you have access to an air compressor, or an artist's brush that can be used in small spaces, etc. It may be difficult to clean the top of the heatsink under the cpu fan - the most likely place to have mung on it - and the bottom side of the cpu fan blades unless you remove the fan. If you have a case fan, clean that too if it needs it.

Also check for mung on the video card fan and heatsink if it has that, and the power supply's openings / fan.

With the cover still off, restore the AC power, start the computer and make sure the cpu fan spins - if it doesn't spin, if you're sure the power supply is working okay, don't use the computer until you have replaced it.
If it spins too slowly, and/or if it makes rattling or screeching noises, most likely to be noticed when the computer has cooled to room temp, has not been used for a while, and then is started up, the cpu fan's bearings are failing - the cpu is likely to overheat as a result of that if it can no longer spin it's full speed - replace it as soon as you can.

Switch on the monitor power if it's off.
Try booting the computer normally.

If that cures what was wrong, you're done.

If not
- sometimes when two IDE optical (CD or DVD) drives are on the same data cable, if one drive is malfunctioning, both of them will malfunction. In that case, try disconnecting the IDE data cable to one drive at a time at the drive (unplug the computer or switch off the AC power to it when you do that), however, which ever drive is still connected must be jumpered master or cable select on the back of the drive when you do that.

- your optical drives cannot work properly if the power supply is not putting out +5v or if it's putting out too much or too little voltage of what is supposed to be 5 volts within 10%.
Iv'e seen that too much of what is supposed to be +5v can damage optical drive's and floppy drive's circuit boards in a short amount of time. Go into your bios Setup and check the current voltage readings for +3.3 v, +5 v, and +12 v, and make sure they're within 10 % of the nominal value; if any of them aren't, you must replace the power supply.

If it is failing, you can usually replace it with any decent standard sized standard ATX PS with the same capacity or greater.

Standard (PS/2) power supply size - 86mm high, 150mm wide, 140mm deep, or 3 3/8" h x 5 7/8" w x 5 1/2" d , or very close to that, though the depth can be more or less for some PSs.

Don't buy an el-cheapo PS.
See response 3 in this:

A frequent reason these days for a power supply failing is a video card has been installed that requires a minimum power supply capacity that is more than a little more than the installed power supply can deliver.

Your power supply must have at least the minumum capacity required to support a system with the graphics card you are using installed, or the max graphics card you might install in the future.
(Onboard video - video built into the mboard - IS NOT A CARD ! )
If that info is not in the ad for the video card, you can go to the video card maker's web site and look up the specs for the model - often under system requirements - the minimum PS wattage, and, more important, the minimum amperage the PS must supply at 12v is stated. If you don't find that, any card with the same video chipset including any letters after the model number has very similar minimum PS requirements. Some power supplies have two or more +12v ratings - in that case, add those ratings to determine the total +12v current capacity.

If you're a gamer.....
In most if not all cases, the max capacity rating of the PS is an intermittant rating. It's recommended that you do not load your PS to any more that 80% of that rating if you are going to be using something that puts a constant load on it, such as playing a recent game for hours on end. In that case, you multiply the min capacity stated for the system with the particular video chipset on the card by 1.25 to find the min. capacity of the PS you should get.

Report •

February 26, 2010 at 15:08:03
If it's just the CD/DVD ROM the first thing to check would be the connections to that unit. They were probably loose and now just need pushing back home.

some other bloke...

Report •

Related Solutions

Ask Question