Can not open my slave drive now?

Maxtor / 6y120p
March 22, 2009 at 01:54:14
Specs: Windows XP
I had this as my slave drive for years and no problems. Then today I did a destructive recovery to my main hard drive, to roll back everything to factory settings. Now it will not let me access my slave drive. It reads it and it is labeled DRIVE E (main hard drive is C and D), but when I click on it to go into that drive, it has a pop up that says "DISK IS NOT FORMATTED. THE DISK IN DRIVE E IS NOT FORMATTED. DO YOU WANT TO FORMAT IT NOW? YES OR NO" Now obvuiously I dont want to because I will wipe out EVERYTHING on the hard drive! It is a 120 gig hard drive, and I am guessing the previous partition is causing this problem now? What can I do to fix this? Please help me here and thank you!

See More: Can not open my slave drive now?

Report •

March 22, 2009 at 06:14:14
What is a destructive recovery and why would you want to go back to factory settings after you made so many changes?

Report •

March 22, 2009 at 06:40:34
You should have temporarily disconnected the slave drive when you formatted/reinstalled Windows, especially if these were PATA/IDE drives sharing the same cable/channel. Try looking at Disk Management see what's listed about the drive:

Did you try taking ownership?

I read about a free program called "testdisk" in another forum. I never tried it so I can't offer any insight as to how it works, but it might be worth checking out:

Report •

March 22, 2009 at 07:53:16
I used testdisk once to recover a Unix partition and it worked.

Report •

Related Solutions

March 22, 2009 at 10:22:45
If testdisk doesn't work, following are some file recovery programs that you can try. However you will need another drive to save the files to.

PC Inspector (freeware)

Zero assumption Recovery
The demo is limited
It will only recover 'up to' four folders per run
But you can make multiple runs


EaseUS data recovery

Report •

March 22, 2009 at 16:50:22
I did disconnect the slave drive when I rolled the main hard drive back to factory settings. Then after I turned off the PC and plugged back in the slave drive, is when it would not read the slave drive correctly anymore.

In disc managment, it says - DISK 0 Basic : (E) 114.5 GB, HEALTHY, ONLINE.

I have the option, when I right click and DELETE PARTITION on that drive, but not on the main hard drive (the one thats fine) But when I click on it to DELETE PARTITION it says "THIS IS AN ACTIVE PARTITION ON THE DISK. ALL DATA ON THE PARTITION WILL BE LOST. ARE YOU SURE YOU WANT TO DELETE THIS PARTITION?"
nOW i AM GUESSING SINCE IT IS A 120 gig HARD DRIVE, AND IT SHOWS 114.5gb IN THE INFO HERE, THAT THE REMAINING 5.5.GB is on the other side of the partition (but not showing) SO if I deleted the partition, it could very well wipe out the 114.5 GB side and NOT the 5.5GB side!! Now losing the 5 gigs wouldnt be a problem, but the 114 gigs WOULD. Any thoughts?

ALso, I just downloaded TESTDISC, but have not messed with it yet. IF all else fails I will try it though.

Report •

March 22, 2009 at 17:13:25
How is the slave drive Disk 0 ?

Report •

March 22, 2009 at 17:37:24
I was wondering the same thing?? Disk 0 is the slave drive, Disk 1 is the main drive that works fine. Is there some way I can put the slave drive as Disc 2? Would that possibly help anything?

Report •

March 22, 2009 at 19:58:00
My guess is that it depends on how you have the jumpers set & the position they are on the ribbon cable. First look at that but don't change it yet.

If you have the money, buy a USB hard drive enclosure or borrow one and connect the drive to another PC with it or even to that PC to back up your data. Then you can start over if you are completely stuck.

Report •

Ask Question