Blank screen no bios

August 31, 2009 at 09:20:13
Specs: Windows Vista
My PC build project shows only a blank screen. The power LED lights up green and the fans spin. The HDD also flashes on once only after power on but nothing on screen . No logo only a NO RGB signal message on monitor. Monitor has been tested and is ok. Also removed hardware: hard drive, floppy , graphics card, memory, and got a series of beeps. Added memory and powered on but no beep and no RGB signal. I suspect the RAM module but could it be CPU or MBoard or graphics card. Any ideas?

See More: Blank screen no bios

Report •


#1
August 31, 2009 at 09:42:31
Getting beeps is a sign that the motherboard and CPU are working ok.
If you get beeps with the RAM removed, that's good.
Your diagnosis is correct. The Ram is the problem.
(edit) Make sure the RAM stick is inserted all the way.

Report •

#2
September 1, 2009 at 07:02:20
Thankyou very much for your reply. It is very helpful as I have limited pc building experience. Have bought a new ram modulee today and will give it a try.

Report •

#3
September 1, 2009 at 08:28:05
You're welcome Dave. Good luck.

Report •

Related Solutions

#4
September 1, 2009 at 10:44:12
You were absolutely right. I installed the new memory module and the pc boots to Bios with a perfect display on the monitor. There were some power shut down issues but I resolved this by reseating the cpu heatsink and fan and securing them correctly. It was caused by too much heat and inefficient cooling. PC now works flawlessly.Many thanks

Report •


Ask Question