Bios does not see SATA drives

February 12, 2013 at 18:50:23
Specs: Windows 7

My bios does not see the SATA drives. When ever I plug a drive into a SATA port the bios does not see the drive and hangs. If I unplug the drive from the SATA port I can get into the BIOS config. Does this mean I have bad motherboard? The motherboard is a Pegatron M2N78-LA.

See More: Bios does not see SATA drives

Report •


#1
February 12, 2013 at 19:22:25

do you have the ports enabled?

Report •

#2
February 12, 2013 at 19:37:19

Yes, it was a working widows 7 machine that would not boot one day. I thought I had a hard drive problem, so i got a new drive but the motherboard will not see anything and just hangs.

Report •

#3
February 12, 2013 at 20:31:26

If a drive is not recognized, it can be only:
1- The hard drive is bad
2- The power is not getting to the hard drive (power supply or cable/connector)
3- The signal is not getting to the motherboard (bad signal cable)
4- Bad motherboard/SATA controller
(Possible other problems too rare to mention at this point)

Begin by eliminating them one at a time. Try a different power connector. Try a different SATA signal cable. Look for a screw you may have dropped when removing the old hard drive that might be causing a short under the motherboard near/under the SATA connector block. Try a different power supply if you have one around (very possible).

You have to be a little bit crazy to keep you from going insane.


Report •

Related Solutions

#4
February 12, 2013 at 21:05:19

I tried the cables ans different drives. Looks like motherboard or power supply.

thanks


Report •

#5
February 13, 2013 at 10:54:59

Where are you actually looking for the SATA drive?

What do you mean it hangs? Is there any message on the screen?

If you have a new drive that is not partitioned & formatted it isn't going to do anything. Are you trying to boot to your Windows 7 DVD?


Report •

#6
February 13, 2013 at 16:07:29

I can't get to the config screen of the Bios. F10 does nothing. When I disconnect all the sata devices then F10 works

Report •

#7
February 13, 2013 at 16:23:54

You may have a defective drive in the system. What drives do you have installed?

Report •

#8
February 13, 2013 at 16:37:55

I have disconnected them 1 by 1 and get the same thing. The only time I can get F10 and into the bios is when there are no drives connected.

Try clearing the CMOS using the CMOS jumper. Be sure to do that while the computer is UNPLUGGED. See the link below.

http://h10025.www1.hp.com/ewfrf/wc/...


Report •

#9
February 13, 2013 at 16:51:38

Try connecting JUST the power connection to the drive/s and see what happens. Strange behavior. How are the drives configured in the BIOS? IDE compatibility mode or AHCI?

Report •

#10
February 13, 2013 at 17:06:22

I tried connecting just the supply and same thing. I have decided to buy a new motherboard.

Report •

#11
February 13, 2013 at 17:20:58

If you only connect the power to the drives and the computer stalls that MAY indicate a defective power supply or a short in the power connector/s to the drives.

Certainly NOT the motherboard if the drives are not even connected to the board and you get the same result. You money to spend though.


Report •


Ask Question