BIOS does not detect SATA devices

July 12, 2008 at 15:06:33
Specs: BIOS, X2 / 2 GB

My MS-7184 motherboard (which supports two SATA 1.5 Gbps devices) does not detect my hard drive nor my DVD burner.

If only the hard drive is connected, the disk activity LED stays on solid. If only the DVD burner is connected, the disk activity light flickers constantly. In both cases the BIOS takes a very long time to determine that no devices are connected.

The devices are receiving power (I can hear the hard drive spin up and the DVD-burner's door opens and closes). The DVD-burner is a 1.5 Gbps device, and the hard drive is a 3.0 Gbps device (jumpered to run at 1.5 Gbps just in case).

Any suggestions?

- Nate


See More: BIOS does not detect SATA devices

Report •


#1
July 12, 2008 at 15:16:41

Did you Enable the SATA controllers in the BIOS? There were problems using SATA optical devices on some of the first generation SATA I controllers. Is this a new build?

Report •

#2
July 12, 2008 at 15:21:27

Wow, I didn't expect such a fast reply!

Yes, the SATA controllers are enabled in BIOS. This is a new build but not a new motherboard; the motherboard and processor are scavenged from an HP "media center" machine of some sort (which I believe used SATA drives in its past life... I'm not certain, I'm not the original owner).

But anyway, yes, the controllers are enabled. Any thoughts on the strange activity LED action? I'm kind of stuck on this one.


Report •

#3
July 12, 2008 at 15:35:07

Try a different signal cable. Why not try another power cable too.

Report •

Related Solutions

#4
July 12, 2008 at 15:40:01

I have tried all combinations of the two devices, two SATA controllers, and two different SATA cables (one new, one old) with identical results.

I am thinking about flashing the BIOS, however I cannot find the necessary flasher and BIOS image that isn't wrapped inside a Windows executable (I run Linux).


Report •

#5
July 12, 2008 at 16:04:01

Before you flash the BIOS, is SATA configured in IDE mode ?

Report •

#6
July 12, 2008 at 16:09:46

I think that I would suspect a motherboard controller problem before the bios. I wonder if the motherboard was zapped by the prior owner.

Report •

#7
July 12, 2008 at 16:12:57

Are either of the drives properly identified in the startup screens? Try disconnecting the optical drive completely. Also, make sure you don't have the BIOS set for a RAID configuration.

Report •

#8
July 12, 2008 at 16:26:12

The BIOS on the motherboard does not allow such fine-grained control over the SATA settings such as picking the operating mode. I went ahead and flashed it (after the hassle of hooking up a PATA CD-ROM drive, creating a FreeDOS bootable disk, etc etc) to a "hacked" BIOS that provides a thousand and one options.

This BIOS indicates that IDE mode is the only available mode for the SATA controller, so yes, that's what it's in.

Also, the drives act up (evident by the activity light) even when the SATA controller is disabled entirely. Any thoughts?


Report •

#9
July 12, 2008 at 16:30:12

Now I am confused. What interface is the harddrive and the optical drive? SATA or IDE?

Report •

#10
July 12, 2008 at 16:31:37

Here's another interesting fact: if I boot the machine and enter the BIOS configuration with no SATA devices connected, then connect a device, there is no LED activity (as you would expect). If I then prompt discovery of devices on the proper SATA controller, the LED activity begins (and after a while the BIOS reports no devices).

Report •

#11
July 12, 2008 at 16:33:53

OtheHill: The goal is to install a SATA hard drive and a SATA optical drive, neither of which are working right now, in any configuration. To flash the BIOS I used an IDE optical drive, which works just fine.

Report •

#12
July 12, 2008 at 16:38:04

Are you connecting drives while the board is powered?

You might consider the possibility the MBoard is bad.

Is the SATA hard drive you are using SATA II? That could be the problem. Look to see if there is a jumper on the drive to set the drive as a SATA I device.


Report •

#13
July 12, 2008 at 16:43:25

OtheHill: Hotswapping SATA drives is safe. Yes, as per my opening post, the hard drive is 3.0 Gbps but I have it jumpered to 1.5 Gbps just in case the motherboard can't do proper speed negotiation.

I'm hoping that positive thoughts and rigorous posting to computing.net will mean the SATA controller isn't busted :) If it is, I'll need to spring for a replacement motherboard - since it's socket 939 that probably means going for an upgrade, which means a new processor as well, etc. :( I could probably find the same motherboard out there somewhere, but I don't know if it's worth the cheaper cost to get an inferior product.


Report •

#14
July 12, 2008 at 17:00:05

IF your SATA controller is defective you could install a PCI based SATA controller card.

If memory serves me correctly there were some early SATA/ IDE boards that were designed strictly for SATA RAID. When folks tried running SATA drives on those controllers the results were spotty. Don't know if your board is one such. You might review the BIOS setting too. The boards I am referring to had strange options.

Did you try to boot without the optical drive connected at all?


Report •

#15
July 12, 2008 at 17:28:39

This isn't one of those boards... this is a very common board found higher-end HP/Gateway/EMachines computers from 2005 or so.

Yes, as I mentioned in my earlier posts, I've tried many things involving different combinations of devices and connections.


Report •

#16
July 12, 2008 at 20:14:30

Well from everything I can tell, the SATA controllers must be shot. I think I'm going to have to pony up for a new motherboard and/or CPU, much to my dissatisfaction. I'll keep an eye on this thread in case anybody has any ideas though.

Report •

#17
July 13, 2008 at 06:49:58

Why not go for a controller card?

Report •

#18
July 13, 2008 at 20:36:21

I had a MSI board where the IDE Controller went out. The BIOS hung when trying to detect the IDE drives, and the POST displayed odd characters in the model number of the hard drive. In Windows, there were Event Log events saying that there was a controller error.

The bottom line is that these kinds of problems are popular with MSI (which, as you probably know, is who makes your board).

WinSimple Software


Report •

#19
July 14, 2008 at 05:20:46

OtheHill: a controller card isn't worth it; I only have one PCI slot available on the motherboard, no avialable PCI-E, and the one open slot is way too close to a fanless GPU with a massive heatsink for my liking.

Rayburn: yeah, it looks like MSI is to blame for this one... or maybe the previous owner, if he was in the habit of taking to the southbridge with a hammer!.

Ah well, thanks for all the help everybody!


Report •

#20
August 29, 2008 at 09:12:22

I'm having exactly the same problem with a SATA hdd and the same MOBO. So seems its a problem with the boards, would love to find an answer for this.

Report •

#21
August 29, 2008 at 09:41:03

superrad, I Googled around a bit when I first had the problem, and I found people with related problems but not the same LED behavior, or even close. Maybe the southbridge is just faulty on this motherboard? I ended up replacing the board with one from a different manufacturer, which worked great.

Good luck!


Report •


Ask Question