Solved Battery is not charging ...

Microsoft Windows 7 professional sp1 64-...
May 31, 2014 at 09:48:15
Specs: Windows 7, 8/8Gb

I've got a new Laptop Dell Precision M4600

The battery is not working and icon in the Task bar states: 'No battery is detected'.

This laptop belongs to my company and they gave it to me to use as a regular user and I don't have admin privilages.

It will take very long time to fix the issue by returning it back to company and etc hence I decided to ask your advice if I could do anything myself to fix the issue.
P.S. After a few attempts to remove and push battery back that warning icon disappeared and battery icon now states: " 0% available(plugged in, not charging)"
AC adapter is original one , computer is new.
Should I just wait at expect that eventually battery will start charging or it's still a problem with battery and/or laptop?

Appreciate any help.


See More: Battery is not charging ...

Report •

May 31, 2014 at 10:13:55
✔ Best Answer
Without the battery - running in mains only... does the laptop work OK?

Has it ever managed to charge the battery?

This is the manual for your M4600 - and incidentally on the Dell website the M4600 is shown as not available...?

Section 38, page 137 -138 describes what the battery indicator light means - in its various states... Suggest you note the info on page 138 especially.

If your company have other M4600 laptops, perhaps borrow a battery from one of those and see if the charge mode operates OK; similarly try/test your battery in another M4600 to the same end?

message edited by trvlr

Report •

June 1, 2014 at 03:47:05
Hi, I am wondering about the ac adapter.

Susja appears to say it is not the one that came with the (new) laptop.

If so, the voltage and/or watts may be incorrect, and thus it might not work.

Good Luck - Keep us posted.

Report •

June 1, 2014 at 04:05:49
Mmm...crossed my mind too. And assorted led indicator light possibilities do include one that will detect whether or not the adapter/charger is appropriate etc.

Report •

Related Solutions

June 2, 2014 at 14:56:52
It was AC adaptor issue
Thanks for suggestions

Report •

June 2, 2014 at 15:07:51
mmm Thank you for posting back... - it doesn''t always happen; and nice when pholks do.

Report •

Ask Question