Battery fully charged but..

Dell Dell inspiron 6000/9200/9300/9400/x...
September 6, 2009 at 22:21:28
Specs: Windows XP SP2

So this is my problem. My battery I thought wasn't holding a charge so I got a new charger and new battery. The battery charges to 100%. Once it gets to 100% I pull the plug out and it dies instantly like there is no battery and it's running purely on electricity. I checked the BIOS and Windows and both say the battery is there. Plus remember this is a new battery so most likely not a defective battery. I try the test power thing and it shows full charge. What I don't get is how it charges the battery but then when you pull the plug it's as iff the battery isn't there. Please any help would be appreciated. I don't know why this is happening and i got the new battery and charger to be sure.

See More: Battery fully charged but..

Report •

September 7, 2009 at 00:19:10
i think it is laptop battery, if yes try upgrading your BIOS, then try getting patch for power management, as it might not getting correct message and some times battery might be faulty try with other battery if it works then change new battery
as the new battery you bought may not storing current
so pl cheak with other battery

Report •

September 7, 2009 at 04:34:25
but i got a new battery the old battery does the same thing and i already upgraded the bios so im not sure what youre telling me to do

Report •

September 7, 2009 at 07:48:32
Don't assume the new battery is good. Not sure how the charger determines when the battery is fully charged but it could be simply shutting off because of elapsed time. Your manual may provide some help.

You may wish to look at the contacts from the laptop to the battery. If one or more are corroded or bent that could explain your issue.

Is the battery an aftermarket unit or an OEM replacement? Same goes for the charger.

Is it possible there is a setting that ignores the battery if enabled?

Report •

Related Solutions

Ask Question