Asus F5RL wont boot up after hinge replacement

November 3, 2012 at 11:10:33
Specs: Windows 7, factory
The hinges were broken/wore out so I bought new ones. Computer was working perfectly fine before. I replaced the hinges (seemed like a pretty simple process), but when I went to boot it back up, the green led at the base turns on but I get no beeps and nothing on the display. When I plug my charger in it the battery charger light turns on also, but still nothing is functioning.

I ended up taking everything apart (down to the motherboard) and cleaning everything making sure i didn't drop a screw down there. I put it back together and it does the same thing. I also tried taking out all the screws down to where I had it apart when I put the hinges in and same thing happens when I try to boot it up.

I did leave the battery in (on accident) when I replaced the hinges, don't know if that matters or not.

ANY ideas would help!

Thanks everybody


See More: Asus F5RL wont boot up after hinge replacement

Report •


#1
November 3, 2012 at 15:36:46
"I did leave the battery in (on accident) when I replaced the hinges, don't know if that matters or not"

If you're 100% sure everything went back together as it should have, leaving the battery in is probably what screwed things up.


Report •

#2
November 3, 2012 at 17:44:05
Well I'm not 100 % sure I did everything right. Like 90% I mean it was pretty straight forward I didn't unplug any connections or anything.

So would you think I caused a short somewhere? What do you think happened when I left the battery in? Where should I go from here?


Report •

Related Solutions


Ask Question