Asus EAH5770 CU Core grapics

January 26, 2011 at 13:19:20
Specs: Windows 7, intel i5 / 8gb DDR3
Just built a new computer from scratch, 2 days later things go bad

computer spec:

Asus Maximus III Gene Motherboard
Intel i5 processor
Asus EAH5770 CUcore grapics
1tb hard drive
8gb ddr3 ram
500W Bottom mounted PSU
Windows 7 home premium as the OS

built it only a couple of days ago and of course it was running just fine, played Battlefield Bad company 2 with no problems but suddenly today while playing my screen started flashing/ going black momentarily until the game suddenly quit (about 1 minute of flashing and lagging) telling me there was driver failure with the graphics card.
I rebooted the computer and the tower lights go on, the motherboard lights all go on and all fans are spinning but none of the lights on my mouse/ keyboard or usb wireless stick go on. Most disturbing is my monitor shows "no signal" while the computer is running. No idea what this means or where things went wrong!

any ideas?

See More: Asus EAH5770 CU Core grapics

Report •

January 26, 2011 at 15:37:30
I would suspect the power supply. What brand is it and what are the specs. Bottom mounted psu's sometimes don't get enough air flow. It's a bad design.

Report •

January 26, 2011 at 18:38:49
its a Thermaltake TR2 500W PSU There is ALOT of empty space in the case for this computer, a solid 4-5 inches between the PSU and video card and then another 4-5 inches between that and the top of the case. The case its self is almost all ventilation. the only solid side is the one the motherboard is screwed onto and the front plate.

Report •

Related Solutions

Ask Question