AGP graphic card upgrade install issue

February 14, 2011 at 13:24:43
Specs: Windows Vista
I am upgrading my old dinosaur Dell Dimension 8200 I have 2G memory, P4 2.4GHz and have upgraded to a 500 watt power supply. My current issue is upgrading the video card. I bought to replace my old NVIDIA 64MB DDR Geforce MX 420.
I have disabled the old card in system settings as there is nowhere to do this in the BIOS. Also uninstalled the drivers then physically removed the old card.
After I have attached the new card to the AGP slot and I power up my hard drive and nothing happens on my screen. I am pretty sure I have all the compatibility details right. Could this be a faulty card? Any help would be greatly appreciated!

See More: AGP graphic card upgrade install issue

Report •

February 14, 2011 at 13:47:23
1st thought, is this new VisionTek vid card compatible with your Dell 8200 system?

- Is new vid card really a 4x/8x, or just an 8x (your mobo only supports AGP 4x/2x @ 1.5V)?
- Video AGP BIOS settings correct?
- Monitor cables plugged into correct video out?
- Does that card require power connection to it?

Yes, the new vid card could be bad also.

Just another stupid saying...

Report •

February 14, 2011 at 14:08:20
Thanks for your input.

I still thought you could use a 8x even though my mobo supports 4x/2x but it will only run at the speed of 4x? Maybe it is the voltage.

There is no option to change AGP BIOS settings in the boot menu and the cables are correct.

I'v been messing with this for days..

Report •

February 14, 2011 at 14:09:56
Your Dell link doesn't work, probably because you put a period after .htm

You didn't make a very good card choice as there are issues with the ATI Radeon HD cards that were retrofitted for AGP. That's not your current problem but I'm sure you'll encounter it once you get the card working. Did you connect the 4-pin floppy power plug to the rear of the card? Did you buy a decent power supply? 500W means nothing. If it's a $20-25 cheapie, you may have actually downgraded.

Report •

Related Solutions

February 14, 2011 at 14:14:47
Some 8x vid cards will work in 4x mode, some may not, should say in manual or on box.

Also, power supply configurations in Dells are very proprietary, you need to make sure that 500W PSU is compatible for your Dell 8200 as well.

Just another stupid saying...

Report •

February 14, 2011 at 14:24:07
Yes I have plugged the 4 pin power.

The power supply is pretty good, it's

I copied this link for my specs

Time to get a new card by the sounds of it. Any suggestions?

Report •

February 14, 2011 at 14:29:05
All video chipsets that support 8X AGP also support 4X AGP

His link to the card shows:
VisionTek 900284 Radeon HD 3650 1GB 128-bit DDR2 AGP 4X/8X HDCP Ready Video Card

Visiontek's support page for it:

3 pages

Did you REMOVE the AC power to the case AT ALL TIMES when you were fiddling around inside the case?

If you didn't, ATX mboards are always powered in some places including some of the contacts in the AGP slot even when the computer is NOT running, as long as the PS is connected to the mboard and the PS is receiving live AC power, and it's switch is switched on if it has one.

AGP cards in particular, and/or the AGP slot circuits, are easily damaged if you didn't do that, because the card and the slots have two vertically staggered levels of contacts.

If your mboard has onboard video, there is no setting in the bios that can disable the onboard video !
For the boards with an AGP socket on the board in addition to onboard video, as soon as an AGP card is placed in the AGP socket, the onboard VGA will disable automatically.

The only thing changing the Intialize video first or Primary Video or similar setting in the bios does on boards that have an AGP slot is inform Windows about what type of card you have installed - that should be set to AGP for an AGP card - if that setting is wrong the video still works in Windows but Windows won't be able to support the AGP features of the specific drivers installed for the card properly.

There is no setting that you can change from defaults in the bios that will cause the AGP card that has no video while booting to have video, unless, possibly, in rare cases, you have a monitor connected via a DVI connection.

Troubleshooting Common DVI Flat Panel Display Issues

Dell Dimension 8200 Systems Solutions Guide

For info about installing an AGP card properly, troubleshooting,
See page 71, 72, 73 in the PDF

Dell™ Dimension™ 8200

Technical Specifications

AGP bus protocols
4x/2x modes at 1.5 V


Report •

February 14, 2011 at 14:35:37
"I copied this link for my specs"

Like I stated, you put a period at the end of the link & that made it useless, that is unless you realize it's there & remove it. Like so:

Why are you investing any money in that outdated system anyway? The video card alone is worth more than the entire system.

Report •

February 14, 2011 at 14:46:35
Yes, the power was always removed when I have been in the case. Going to check the trouble shooting guide.

It certainly is an outdated system however a good way to learn your way around a pc is by upgrading. Albeit frustrating I have learnt plenty in the last 6 months. In regards to $ you are right but it's a hobby.

Report •

February 14, 2011 at 15:04:42
Yeah, I'm a hobbyist myself, been at it for over 15 yrs. But if I'm going to spend my hard earned money, it certainly wouldn't be on a P4 system with a 4X AGP slot & Rambus memory.

Report •

Ask Question