Solved AG Neovo M-17 Monitor - screen goes blank briefly

Ag neovo / M-17
April 26, 2012 at 08:24:37
Specs: Windows 7
I have had the monitor for around 5 years, although it has only be used for around 3.5 years.

This is a very strange issue.

About 15 minutes after turning the monitor on yesterday (for the first time in a while), it briefly "blank" screened (with the power still on) and then returned to its original state (without me touching the computer). It did this twice in around 40-60 minutes. Afterwards I swapped the DVI cable round with a new one and tested it for around 60 minutes. No such issues.

Yet the original DVI cable works fine with my other monitor (Samsung).

So my question is, could it be a faulty DVI cable, or is it some internal hardware issue within the monitor itself?

Could the DVI cable switch just be a coincidence?

I have heard explanations along the lines of faulty inverters and/or capacitors. I have also heard that it could be a surge in power that affects the monitor.

What do you guys think?

See More: AG Neovo M-17 Monitor - screen goes blank briefly

Report •

April 27, 2012 at 22:48:28
From my experience those symptoms usually indicate a faulty inverter or capacitors, but assuming the monitor is not connected through a surge protector that could also be the problem.
I would strongly advise you to use a surge protector or an automatic voltage regulator.

Report •

April 28, 2012 at 09:02:40
✔ Best Answer

Thanks for the reply. Yeah, given the length of time I have had the monitor a faulty inverter or capacitor was my bet.

However, I have swapped the cable around and tried the monitor for an extended period of time (+10 hours). I had no further black screen issues. I can only think that it was an issue with the cable and monitor port connection.

Just for the record; I do already have a surge protector.

Report •

Related Solutions

Ask Question