Topic: GTA IV lag on 9400 GT

Gigabyte / P31-ds3l
January 31, 2009 at 07:42:00
Specs: Microsoft Windows 7 Ultimate, 2.6 GHz / 2045 MB
I have bought a new Nvidia geforce 9400 GT 1GB graphics card and gta 4 really lags on it even on lowest settings. I have 185.20 drivers. Is there any way how to run GTA IV without lagging?

See More: Topic: GTA IV lag on 9400 GT

Report •

January 31, 2009 at 08:04:01
"Is there any way how to run GTA IV without lagging?"

Sure, get a decent video card.

Did you look at the system requirements? Your card isn't supported. The 9400GT is extremely low end. And 1GB memory on a card such as that is totally's just marketing ploy to sucker people into buying it, thinking they're getting a decent card. You should have asked for advice BEFORE you bought the card. I suggest you return/exchange it for something different. Did you buy it online? If not, you more than likely paid too much...more than $40-50 & you got ripped off.

The following article will help you to choose the right card..make sure to select one that at least meets the minimum game requirements. And if possible, buy online from a site such as

Here's the graphics requirements for GTA IV (they should be on the box):

Minimum graphics: 256 MB Nvidia 7900 / 256 MB ATI X1900

Recommended graphics: 512 MB Nvidia 8600 / 512 MB ATI 3870

Report •

February 1, 2009 at 02:51:08
The 9400GT is pretty much useless. Get a 9600GSO and you'll be happy.

Got mine for $79.00 awhile back when newegg had a special going on, too bad that ended.

The 9600gso is very similar to the 8800 series except it uses alot less power and runs alot cooler. A good buy.

PM9600(1 ghz G4)
512mb RAM
36gb SCSI
ATi 9250 PCI

Report •

February 10, 2009 at 01:15:12
If you have 2 GB and above ram you can play GTA 4 without any lag at medium settings. I have the same card but 512 MB version with 2 GB system memory and i get 30 to 40 FPS on this game.

Report •

Related Solutions

March 7, 2009 at 15:50:35
I'm in need of advice too : i have nvidia 8600gt with 512mb ram however the game is soooo laggy and when i play, the map doesnt load at the bottom left. if i press ESC it also doesnt show anything but locks my char.

ESC again drops me out of the "invisible menu" and i can continue struggling to play.

got the new patch hoping that would fix joy.


Now here's where the issue must be.

I have a 3.4ghz intel p4. old skool now but running other new games fine. even ones requiring duel core etc.
Yes i realise that it says this game requires a duel core machine, however this is tripe!
The little FPS test runs perfectly. (before patching was choppy too)
installed the new nvidia beta drivers as requested.

3gb ram so match with all minimum system spec except the processor.

Anyone got any hints? Running on as LOW as possible.

PS dont reply with "get a new processor" i'm asking for help to get ROUND the problem at no cost.

Report •

Ask Question