Nvidia Geforce Go 7600- Odd Artifacts Problem

Electronic arts Ea games the sims 2 doub...
November 18, 2009 at 04:19:36
Specs: Windows Vista Home Basic
ugh. I had this problem FIXED once, but have had my computer completley cleaned out and have since forgotten how I did it.

Im using a Nvidia Geforce Go 7600 with updated drivers playing Sims2 : Double Deluxe.
During gameplay, I get some weird graphical artifacts but ONLY during build and buy mode. When I switch back over to live gameplay [where the sims are actually moving around], the artifacts are GONE! o.o

As i said before, I had this problem solved once, so i know its not a graphics card incompatibility, overheating, or dust/fan issue. There was something I tweaked or downloaded. And I cant remember what I did! Can anyone offer some ideas to help jog my memory?

See More: Nvidia Geforce Go 7600- Odd Artifacts Problem

Report •

January 8, 2010 at 23:36:35
hi. i am having the same problem. can you tell me what you did
to fix it? thanks.

Report •

February 5, 2010 at 16:13:40
I had this problem, my hardware sis 651 chipset, agp, GS7600. Fixed by downloading and installing sis agp(gart) driver v1.21 from sis.com. Changed ms updates to manual to stop it updating this driver. Graphics now perfect. Good luck.

Report •

February 6, 2010 at 10:24:20
artifacts happen when u overclock too high or the card is damaged but since u said that u did tweak something then check if u have installed any overclocking software like atitool
or rivatuner etc than try to restore default clocks

Report •

Related Solutions

Ask Question