low fps in wow

April 29, 2011 at 18:26:08
Specs: Windows 7
hi i have a 5870 1 gig 256 bit fxf with 8 gig mem and crosshair iv formula mbraptor hard drive the 10,000rpm ultamate cooling5 140mm fans and 1 230mm in the side i have started geting low fps in wow and i have done everything i can think of to fix this any clues and this card is new my old card was a shaphire 5870 1 gig thaught it was that.

See More: low fps in wow

Report •

May 2, 2011 at 12:56:05
If thats your setup, then its probably your connection. Whats your latency? Anything over 500-1000 MS and thats why your FPS is crashing.

Do you monitor your temperatures while gaming? Do they stay in the 40's-50's?

WoW can run fine on INTEGRATED graphics. A 5870 should literally play the game max with no problems.

If its not your internet speed, check your drivers (have you updated them recently, if so, maybe they are the cause- go back to an older driver setup)

Also, make sure you are running WoW as OpenGL. To do this:
Right click your WoW desktop icon, or the menu icon used to start the game, and select properties. In the "Target" box, simply go to the end of the text listed there, hit the spacebar once, then type -opengl
It should look something like this when you're done: e.g. -

C:\Program Files\World of Warcraft\Launcher.exe -opengl

Then, just click "apply" and "ok". Next time you click it to run the game it will run in opengl (which it should be doing).

Do you play any other games? Are you getting poor performance in those as well, or is it only WoW?

Report •
Related Solutions

Ask Question