Lag in all PC Games

Activision Call of duty 4: modern warfar...
June 9, 2010 at 15:01:28
Specs: Windows Vista, 6gb
Hey everyone. I've been playing FPS online for about 4 years, and just starting about 5 months ago I have terrible lag. About a year ago I had no lag at all, and I still have the same computer setup, same games, same internet, same everything. I moved away, then came back about half a year ago only to find myself lagging like crazy on every game (I play CoD4, CoD:MW2, BF2, and BF1942). Comcast is my ISP. They came out last week and told me that the internet is working perfectly fine...which can't be true because I often have trouble opening web pages too. According to SpeedTest I am getting 20mb/sec. download speed (I pay for 12) and a 2.8 upload speed. I'm not very tech-savy, but here's my computer specs:

Operating System: Windows Vista Home Premium

System Type: 64-bit Operating System

Manufacturer: Dell

System Model: Studio XPS 435MT

Processor: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz(8CPUs), ~2.7GHz

Memory: 6134MB RAM

Page file: 3345 MB used, 9118MB available

DirectX Version: DirectX 10

Graphics Card:

Name: ATI Radeon HD4670

Chip Type: ATI Radeon Graphics Processor (0x9490)

DAC Type: Internal DAC(400MHz)

Approx. Total Memory: 3315MB

Current Display Mode: 1024 x 768 (32 bit) (60Hz)

I don't really know what all of that means, but if anyone can help me try to solve my lag issues it would be greatly appericiated.



See More: Lag in all PC Games

Report •

June 9, 2010 at 22:16:35
What about non online games? Do they lag?
20mb/second is faster.
U have good system but if your gamer the monitor and v-card need to be changed.

Report •

June 10, 2010 at 13:39:11
bandwidth is one thing, but ping is what you need for online games.

What kind of ping time are you getting in ms?

PowerMac 9600(1 ghz G4)
512mb RAM
50gb SCSI
ATi 9200 PCI

Report •

June 10, 2010 at 15:07:19
In games that don't require the internet, or singleplayer games, it runs smoothly, no problems at all. When I play in servers located in my state I run an average 50 ping, but when I lag it goes up to 999 or just disconnects me from the server. According to SpeedTest it says me ping is 10ms.

Report •

Related Solutions

Ask Question