Cannot play game after installation

October 26, 2011 at 12:47:29
Specs: Windows Vista
I have just installed Dawn of war 1 to my desktop pc. straight after installing it i played it no problems at all now however when i click the DoW icon with the disc in the drive it wont play and the mouse icon changes to one of a spinning cpu usage goes straight up to 100% and then nothing happens. the disc icon just spins for hours. i left ot for 4 hours this afternoon just to see and it was still just spinning. and as a side effect perhaps i cannot eject the disc from the drive.. any ideas? i dont know specifics about my pc. all i know is that its an IQ desctop with amd processors and an ati 1500 graphics inbuilt. windows vista 32bit

See More: Cannot play game after installation

Report •

October 26, 2011 at 20:44:14
"i dont know specifics about my pc"

Pretty tough to help you without knowing what you're working with.

"ati 1500 graphics inbuilt"

Never heard of it.

Report •

October 27, 2011 at 02:11:20
Ok i dont know if this is more helpful
AMD Athlon 64 processor 3500+ 2.20 gHz
1gb Ram
32 bit vista operating system
ATi radeon zpress 1150 graphics

Report •

October 28, 2011 at 09:13:30
so the disk is stuck in your pc?
turn the laptop back on and eject it, and why do you play it with a disk in the drive? the game plays fine with no disk in the drive at all. plus your system is weak it ran the game ok bcz lucky u this game has low specs but still,

computers are a second home

Report •

Related Solutions

October 29, 2011 at 13:09:14
it wasnt the disc being stuck i was trying to solve. i could figure it out how to get it out it just wont play. plus it does need the disc to be in as it always asks me to insert disc 1. yeah my pc is crap but if it played the first time why not any other time

Report •

Ask Question