Cannot Connect to Servers?

June 9, 2008 at 17:30:27
Specs: XP SP2, Pentium 4 HT 3.00GZ 2.5Gb
Hey I've tried everything I can think of any more and i still can't fix this. I installed Crysis the otherday however, i couldnt connect to any multiplayer games it wouldnt connect to the server. Its bundled with gamespy comrade and this wouldnt connect to its server either. I then uninstalled Crysis and installed F.E.A.R. Combat multiplyer i also couldnt connect to the server with this, it is bundled with gamespy arcade which i also couldnt connect. I then thought to try to log into xfire which i knew worked, this also failed and couldnt connect to the server. I then thought it could be something to do with me installing XP SP3 so i uninstalled this and tried again still nothing. For each of the above i disabled my zonealarm firewall, windows one is always disabled, and fowarded all the necessary ports on my netgear gd834gt router. Still couldnt conect. I rang my ISP and they said everything was fine with the connection, I can still browse the internet. However, when i tried to install a firmware update for my router when i tried to right click --> save link as it said it could not connect to the server. I then borrowed a laptop downloaded the file and installed it onto my computer. I dont think it has anything to do with the router because he could connect to te Crysis server through my wireless. I've downloaded winsockxpfix to try to sort it out and TCPoptimizer to try and sort my connection out but still no luck. I cant think of anything else but to either uninstall my netgear wificard and reset my internet connection or if its somethign more serious then that reinstall windows :( which i really dont want to do. Any help would be a godsend. Thank you

See More: Cannot Connect to Servers?

Report •


#1
June 9, 2008 at 17:49:07
Plugging your computer directly in to the cable/dsl modem with an Ethernet cable will help isolate the problem. If you still can't connect, the problem is with your computer. If the problem goes away, it's an issue with your router.

Try that, and post back with the results.

-Ryan Adams
http://RyanTAdams.com


Report •

#2
June 10, 2008 at 03:37:56
Nope I just tried that and it hasnt worked. I can still connect to the internet but not to any servers...

Report •

#3
June 10, 2008 at 12:00:11
Well then the problem is with your computer, and it's pretty much guaranteed it is a software issue.

I've seen this happen with Norton System Works, where even though the firewall appears to be disabled, it isn't. I've personally seen it happen with zonealarm, but there is a first for everything. Try uninstalling zonealarm. Then make sure the Windows firewall si off (sometime the uninstall will reactivate the default windows firewall.

-Ryan Adams
http://RyanTAdams.com


Report •

Related Solutions

#4
June 10, 2008 at 13:14:12
Ive tried that. Ive also tried turning off the firewall inside zonealarm. And shutting it down. I've disabled my firewall on my router and still no luck too.

Report •

#5
June 10, 2008 at 19:55:50
Have you tried running in safe mode? I can't imagine the games will run well, but you might be able to start one long enough to see if they will connect?

-Ryan Adams
http://RyanTAdams.com


Report •

#6
June 11, 2008 at 07:31:36
When i run start mode i cant connect to the internet. It says acquiring network address... Then nothing. I tried connecting by ethernet but the same thing happened. Is there anyway to sort this?

Report •

#7
June 11, 2008 at 11:38:37
You will have to start in "Safe mode with networking".

It's almost guaranteed your wireless won't work, so you will have to connect with a wire while in safe mode.

-Ryan Adams
http://RyanTAdams.com


Report •

#8
June 11, 2008 at 12:54:13
I tried it in both :/ and it said the same thing. Are ther eany setting i can change to make it work in safe mode?

Report •

#9
June 11, 2008 at 13:54:57
Heres a link to a picture of the services i have running on my computer. I know i dont need ALL of them runnign but i dont know what ones to remove. Could one of these be stopping the connection?

http://img206.imageshack.us/my.php?...


Report •

#10
June 11, 2008 at 15:17:27
Quick question. What is windows presentation? I uninstalled it a while ago thinking it was literally a presentation however i just looked it up and it appears to be a program. Could this be the cause of the problem?

Report •

#11
June 11, 2008 at 16:10:36
I noticed that according to your screendump found at http://img206.imageshack.us/my.php?... your Windows firewall is still active (alg.exe), this might be a problem but not neccesarily.

If I had a simular problem I would try a different approch than you described, I would do it step by step as follows.

1. First step is information gatherning, the first thing you must check is that through your entire PAN (Personal Area Network) you must be able to have the online gameing ports
accessable. This as well as the Windows firewall (if online), ZoneAlarm and the router if it has built in firewall. Thus in F.E.A.R. these are TCP/UDP ports 27888, in CS-Source 27015.

In Crysis you have a serious amount of ports which you must been able to access both ways depending on if you will host your own online game server or if you just want to join others. You will find the ports on url provided
http://forums.electronicarts.co.uk/...

Keep in mind that these ports must have access to your computer (both) ways in order to work, otherwise there is NO WAY that you are able to access nor play the games online.

2. If I were to do another thing, I would probably check if there were proper connection towards the IP adress towards were I should access. I would ping them to make sure that thay were up and running.
This can however be missleading since you can easily disable ICMP (thus ping).

3. I would if posible if non of the above tips will not make it work try to browse forums were online gamers might have encounter simular problems.

There are however a few trick left in my arsenal which I will not bother you at this point, but will happily provide if none of the above tricks will not work.

I would not give up chazzer666, but that is just me. :)


Report •

#12
June 11, 2008 at 17:28:20
alg.exe will still be present even if the firewall is set ot "off."

Try going to your control panel -> administrative tools -> services. There is a service called "Windows Firewall/Internet Connection Sharing". Right click on it and stop the service.

Also, while in there, "status" heading. This will group all of the services that are started together. Read through those and see if you find any related to zone alarm. If yo do, right click on it and "Stop" the service. Try your games then.

To revert all those changes back to their original states, just restart your computer.

PS: I just noticed you have something from AOL running. Make sure AOL doesn't have any services running or process started/running.

-Ryan Adams
http://RyanTAdams.com


Report •

#13
June 12, 2008 at 06:22:50
YES OH YES YES YES YES YES YES!!!!!!!!!!!! FIXED IT THANK GOD!!!! WOOOOOOOOO

I think it was peer guardian 2 ¬¬

Gonna restart without it loading see if that helps. Then again it could be anything ive changed. Ive uninstalled zonealarm avira disabled the firewall on my router and closed a few other running programs :)

Thanks so much for your help. Deffinately comming back here to get if i get stuck in future.


Report •

#14
June 12, 2008 at 11:32:15
Peerguardian will definitely do it.

-Ryan Adams
http://RyanTAdams.com


Report •


Ask Question