Annoying lag in easily playable games!

August 28, 2010 at 17:11:41
Specs: Microsoft Windows XP Professional, 2.992 GHz / 3326 MB

I have been playing several games on my computer recently, and in some, the performance has been much less than satisfactory. I have:

Intel pentium 4 processor 3.00Ghz
ATI Radeon 4670 512MB
250GB Hard Drive

My PC says I do not need to defrag my hard drive, I have plenty of space in it and I very often disable unnecessary background programs temporarily to increase gaming performance. I have a game called Mount & Blade, and the game doesn't particularly have brilliant graphics, even on the highest settings, and it is a fairly small game (under a Gig). I have to turn the graphics down nearly completely to the lowest settings during pretty large battles: when there is nothing on the screen, I have 100-150 FPS, but as soon as soldiers start appearing, the FPS just nosedives, occasionally hitting a rock bottom of about 6 or 7 FPS. I find it impossible to play with anything higher than low settings and yet still maintain coherent playing (its says, in the graphics options, that I should have over 310% performance, because I also turned the resolution down a lot and basically everything else). Another game I have, Oblivion (I went onto system requirements lab, and it said that I should be able to play it near to its peak), I play on mainly low graphics ( I have AA on about 2X, textures on medium, low resolution) but on some occasions, even though I have many performance mods such as OO and Streamline and quiet feet and flickering lights on, the game lags quite a bit and is choppy, not to unplayable levels, but it is frustrating. I often download mods such as castles as homes and things like that, and they lag it to hell when I come within 5 metres of the place...very annoying.

The only thing that could be causing this, i think are my video card drivers...I have video card drivers that are nearly out of date a year (8.681, and the most recent are 10.8, I think). I would love to update them, but to be honest, I have tried ten times to no avail (four times yesterday) and every time, the computer has died and I've had to use system restore...I try to delete every trace of the video card drivers (including CCC), but it won't let me delete CCC (Setup.exe has failed..blah blah blah) and so the drivers conflict, and I go to a black screen after rebooting the PC when I install the new ones...and driver cleaner pro for some reason won't get rid of that evil CCC (I delete EVERYTHING....display drivers, install manager, EVERYTHING... but the CCC entry remains in the Add/Remove programs list, and I can't get rid of it, and the install manager won't let me uninstall the blasted thing).

Lol okay, sorry for ranting and rambling on for so long but it's late over here and I'm sick of trying to update them without success...could they be causing the performance issues in my games, and, if so, is there a way to solving the problems that I am having with updating my old drivers??

Thank you!

See More: Annoying lag in easily playable games!

Report •

August 28, 2010 at 17:21:21
Use ATI Catalyst uninstaller to uninstall old drivers.

E8500 | 3GB | 320GB | 9800 GT 1GB @ 720/990 | HP w1907 @ 1440 x 900 60hz| Win7 Ultimate x64

Report •

August 28, 2010 at 17:53:54
Wow, thanks...I can't believe that I haven't come across that software before :)

However, it still comes up "Setup has encountered a problem and needs to close...etc etc", and when I check Add/Remove, the Display driver is gone, but the CCC and the Install manager are still there :( Please help!

Report •

Related Solutions

Ask Question