eMachines T5452 Digital Media Manager and Front USB Ports

November 24, 2012 at 13:36:39
Specs: Windows XP, AMD Athlon 64/2gb

This is the first time I've had the issue, actually it was working yesterday. For those that say I need to get the eMachines driver, I can't install it because I don't use Vista or 7. I'm running XP Corporate.

As it stands, I have SM Bus Controller and PCI Simple Communications Controller marked under device manager, yellow and red respectively. They have been like that since I installed XP as I have been unable to find the chipset driver.

I have checked all the connections, the rear USB ports work fine as do all of the other connections, including the microphone and headphone jacks. It seems just the Digital Media Manager and front USB Ports aren't working.

It is an eMachines T5452, Part No: 95216V0260, S/No: GC584 600 07765.


See More: eMachines T5452 Digital Media Manager and Front USB Ports

Report •


#1
November 25, 2012 at 02:28:49

Have you checked that the front usb ports are actually connected? There will be a cable running from the front panel of the case to a USB header on the motherboard.

The 'PCI simple communicatons controller' is simply a modem which, if you don't use, is no loss. However, the SM Bus controller is an important missing driver which installs as part of the chipset driver, so it would be a good idea to try & track down that one, possibly from the motherboard manufacturer's website (check the model number when you are checking the USB connection mentioned above.

"I've always been mad, I know I've been mad, like the most of us..." Pink Floyd


Report •

#2
November 25, 2012 at 08:00:58

The front ports are connected, I checked. As for the SM Bus Controller, I searched for two hours trying to find the drivers. I would ask eMachines but unless you pay them they don't offer you any support what so ever. I will never own another one of these, I know that for sure. I've already had to replace the DVD drive.

Report •

Related Solutions


Ask Question