Failure reading drive D ?

March 18, 2006 at 06:55:24
Specs: WinMe, P3 750 MHZ 256MB SDRAM

When I do to start, run and type command ,instead of the DOS box opening a it always did B/4 in C:\Windows\Desktop , it starts out saying "Failure reading drive D (thats my CD-RW drive ,my H.D. is C! Then i gives me three options Abort ,retry, fail? If I click on retry ,it gives me the same failure reading drive D ,same with fail ,howevr if I click on abort ,it will then go to the C:\Windows\Desktop . How do I correct this problem ,I have check prorperties of drive D in device manager and it is working properly .I've tried the CD switch ,hoping it would stay with he C:\Windows\Desktop , promt ? Anyone know how to permantaley correct this minor inconvience from coming up everytime I open DOC with the, run, command ?
Thank You Nick

See More: Failure reading drive D ?

Report •


#1
March 18, 2006 at 07:15:01

First, what "command" are you running?

"I've tried the CD switch ,hoping it would stay with he C:\Windows\Desktop , promt ? "

I have no idea what that means.


If at first you don't succeed, you're about average.

M2


Report •

#2
March 18, 2006 at 07:25:06

I apoligize ,I forgot to proof read my post ,something I should always do ,I meant the CD command "Change Directory" Iam ,as you can most likley tell not very knowlegable on using DOS ,however this is somethig new happening when I do open the DOS box .They few commands I use in DOS are usally to check certain versions of items installed. Otherwise I do not do alot ,if any editing within DOS. Back to my reason for posting ,do you have any idea why it would start out ,when I open the DOS box stating "failure reading drive D ? Abort,retry,fail?
Thsnk You Very Much ,Nick

Report •

#3
March 18, 2006 at 07:35:45

What command are you trying to run?


If at first you don't succeed, you're about average.

M2


Report •

Related Solutions

#4
March 18, 2006 at 15:35:52

Most likely your cd or cd drive is bad. (Perhaps Franki should have nagged you to post in the hardware forum. I guess in his blinding drive to admonish misposters he must have overlooked that.)

Try booting with a 98 or ME bootdisk, choose cdrom support and do a DIR on a data (not audio) cd. Some bootdisk temporarily change the cdrom drive letter so pay attention to what letter is specified when booting up. You may need to hit R (for retry) a few times to give the cdrom time to spin up.

If it gives a directory listing then the problem is in windows. If it doesn't then the drive or cd is bad.


Report •

#5
March 18, 2006 at 21:08:05

you could make sure your loading a cd rom driver when your booting to dos in the autoexec bat file.

to tell you the truth im not sure which one it is asni somthing ???? maybe some one more intelegent then i could helop with that.
but that might be your problem you dont have the dos drivers to talk with the cd so its inaccessable.


Report •

#6
March 18, 2006 at 22:30:40

Never too sure just what Nick means, in any of his frequent posts in WinME

This is no exception - the connection to DOS is... pretty tenuous

Try putting a CD in the drive - maybe that'll stop the error message

as well:

"asni somthing ????"


'???' indeed - if you mean ANSI.SYS, that console driver has nothing to do with CDs or WinME

We've heard that a million monkeys at a million keyboards could produce the complete works of Shakespeare; now, thanks to the Internet, we know that is not true


Report •

#7
March 19, 2006 at 02:02:39

Might be a bad ms-dos prompt.pif file. Try creating a new one.

Drag the current ms-dos icon to the recycle bin. Then right click on the desktop. Choose NEW--SHORTCUT. Under 'command line' type in C:\WINDOWS\COMMAND.COM and click 'next'. Then drag the new icon to wherever you want it--usually PROGRAMS--ACCESSORIES.


Report •

#8
March 19, 2006 at 02:36:03

We still don't know command he is trying to run.


If at first you don't succeed, you're about average.

M2


Report •

#9
March 19, 2006 at 06:25:14

So into the RUN box you are typing COMMAND, is that correct?


If at first you don't succeed, you're about average.

M2


Report •

#10
March 19, 2006 at 06:39:49

Correct ,I go to Start button on taskbar ,run ,type command ,small DOS box opens with failure reading drive D Abort,retry,fail

If I chose abort ,it then changes it to the C:\Windows\Desktop, chosing retry or fail only has the first reponse repeat itself ?
Thanks fo your interest !
Nick

Report •

#11
March 19, 2006 at 06:50:22

Type SET and look at your:

PATH
TEMP
TMP
HOMEPATH
SystemDrive
USERPROFILE


These may vary by version, but you get the idea.


If at first you don't succeed, you're about average.

M2


Report •

#12
March 20, 2006 at 06:35:34

Hi Mechanix2Go,
I went ahead and followed your directions on typing SET after the DOS box opened and here is the first few lines ,it listed several lines more of info ,however I will have to post back later with entire display of what came up ? For now this is what first appeared > SET
Prompt=C:$p$g
Temp=C: \WINDOWS\TEMP
TMP= C: \WINDOWS\TEMP
COMSPEC=C: \WINDOWS\COMMAND.COM
HOME= d; \home
PATCH=.;d\cygwin\bin;d:\
Like I stated there is more that opened when I typed in set ,hopfully this will be of some help in you helpig me to get this back to opening as it always did B/4 the "failure to read drive D" started appearing ?
As always your help greatly appreciated !
Thanks Nick


Report •

#13
March 20, 2006 at 06:37:20

Sorry where I typed patch ,it was path ,another typo !
Thanks Nick

Report •

#14
March 20, 2006 at 12:49:57

I think the problem is with the HOME= line. but the ME machine I checked didn't have that line when I ran SET. And I think it's odd that it'd be pointing to your d: drive.

The value is probably specified in autoexec.bat so you'd need to edit that file. For ME, autoexec.bat is a hidden file. There's also a non-hidden autoexec.bak that should be the same as the .bat file. So you should probably edit both.

Wait for Mechanix2Go to post back before doing anything as he may have other thoughts.


Report •

#15
March 20, 2006 at 13:30:20

OK, I was fiddling around with the ME machine to see if I could mimic your error based on the SET variables. Adding a HOME= line made no difference. Then I changed my

PATH=C:\WINDOWS;C:\WINDOWS\COMMAND

to

PATH=D:\WIN98;C:\WINDOWS;C:\WINDOWS\COMMAND

and got the error you mentioned when I ran 'command'. I then changed it to

PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;D:\WIN98

and didn't get the error. In the first example the OS attempted to go to d:\win98 first, saw nothing was there and gave the error. In the second it went to c:\windows first and found 'command' and stopped there. So it never got to the D: drive.

You need to change your path command so that the windows folders are first. That is, something like this:

PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;D:\cygwin\bin;d:\

You may want to just remove the D: drive references if you don't recognize them.

I think you can do the editing by running msconfig and clicking the 'environment' tab. You could also use notepad or the dos EDIT command, but with dos you need to use the ATTRIB command to unhide it first.


Report •

#16
March 20, 2006 at 16:32:43

Hmm, well I guess you don't need to unhide the file before using EDIT. I thought I knew this stuff :-)



Report •

#17
March 20, 2006 at 22:28:32

Obviously not DiC.........

Maybe try:

RUN
MSCONFIG
ENVIRONMENT:

Check the boxes only for;

PATH C:\WINDOWS;C:\WINDOWS\COMMAND.COM
PROMPT $p$g
TEMP C:\WINDOWS\TEMP
TMP C:\WINDOWS\TEMP


This would of been answered days ago in the correct forum>>>>>>>>>>>>>>>>


Report •

#18
March 21, 2006 at 00:00:22

Unless he didn't enter his path line correctly in #12 then it doesn't contain the windows path so he'll need to do more than check/uncheck boxes.

And didn't I mention msconfig--environment? Let me check that to make sure. . . Why by golly, yes I did. Well thanks for the redundancy.

How do you know, are you psychic too>>>>>>>>>>>>>>>>>>>>>>


Report •

#19
March 21, 2006 at 05:01:09

Thanks DAVENCAPS ,fanki for the directions ,I think I will try the msconfig ,enviroment and see if that corrects the DOS opening back to C:\WINDOWS\DESKTOP ,as it always would come up B/4 ,instead of "fail to read drive D" ? I will post back tomarrow after I attempt the change ! Your patience with my ignorance in this area is comendable and greatly appreciated ! Iam going to copy and paste your replies and hopfully be able to play around with this when I get home from work !
Take Care ,Nick

Report •

#20
March 21, 2006 at 05:40:12

I opened MSCONFIG ,and the eviroment tab and sure enough those inputs are as they where in DOS, under HOME box it says d:\ ,the TEMP and TMP box have C:\WIMDOWS\TEMP under both of them ? Under HOME it says d:\home,and under DISPLAY its says localhost:0 then last box listed it says PATH .;d\cygwin\bin;d\cygwin\usr\bin;D:\cygwin\usr\local\bin;D:\usr\X11R6\bin;d:\gs\gs8.00\bin;d:\gs\gs8:00\lib;C:\WINDOWS;C:\WINDOWS\COMMAND;C:\Program Files\Execcutive Software\DiskeeperWorkstation\
WHEW ,that was not easy for me to type all that our correctly ! I remember not that long ago I dowloaded a free trial version of DiskeeperWorkstation , I've since uninstalled it from my system ,since I have Norton Utilities already installed and use its speed disk utility ! Now that I have listed whats in the enviroment list with te boxes checked ,could someone give me the directions step by step on what to edit threse lines with ,or should I simply ucheck for it to load the enviroment variables under the general tab in MSCONFIG ? Thanks again ,hopfully this will end this very long post ,b/4 I upset someone !
Thanks Again ,Sincerely Nick

Report •

#21
March 21, 2006 at 07:21:03

You highlight each seperate entry and press EDIT, change where they are pointing to as stated below, jeez it aint rocket science:

PATH
C:\WINDOWS;C:\WINDOWS\COMMAND.COM

PROMPT
$p$g

TEMP
C:\WINDOWS\TEMP

TMP
C:\WINDOWS\TEMP


STILL HAS ABSOLUTELY BUGGER ALL TO DO WITH STANDALONE DOS EVEN AFTER 20+ POSTS


Report •

#22
March 21, 2006 at 14:34:20

I think the non-dos aspect of this thread has been made abundantly clear. I don't see that there's any reason to bring it up in every single one of your posts.

Nick, if you can't get it edited, post back and, in keeping with the theme of this forum, I'll tell you how to do it in dos.

But it looks like you recently installed some software that mangled those settings. It is definitely the D: drive references in the PATH that occur before the windows folders that is causing your problem. Probably just leave your path as:

C:\WINDOWS;C:\WINDOWS\COMMAND;C:\Program Files\Execcutive Software\DiskeeperWorkstation\

and totally remove the rest of the stuff in that line.

Set the temp file location back to the C: drive as franki mentions. You can probably remove the HOME line. The ME machine I have doesn't even have that and yours points to D: anyway.


Report •

#23
March 22, 2006 at 06:34:28

I want to thank everyone invovled in this post ,Iam sorry for posting it in this forum ,which apprently was not the correct one .I have some ?'s about MSCONFIG in WindowsMe and the Enviromet Variables, I will make a post in the WinMe forum on that !
Thanks Again to All
Nick

Report •

#24
March 22, 2006 at 12:39:20

You're welcome. Normally misposts are no big deal. But for some, the dos forum seems to be some kind of religious shrine and they get their shorts all in a knot when a non-dos thread shows up.


Report •

#25
March 23, 2006 at 12:41:59

Whatever DiC head, it took 4 days longer to get an answer, even answers to questions he never asked. If he had posted in the correct forum he would of saved himself 3 days, we will never agree so keep on answering and I will keep on pointing them elsewhere.

Report •

#26
March 23, 2006 at 12:48:17

Hi DAVEINCAPS, I've been away recently..... who's franki??????

It's a good day when you learn something


Report •

#27
March 23, 2006 at 13:49:14

I am Franki and I object to the snide retort in the other post.

This poster is using ME and was asking a question about the "MS-DOS Prompt". That is totally outside the scope of this forum.

Some of the posts got pulled but apart from M2GO and DIC only JBoy responded stating the link to MS-DOS was tenious.

The whole point was that if NR had posted in the ME forum he would of got a quicker answer, and as is stated in the header questions relating to "MS-DOS Prompt" in Windows should not be posted here.

JW wrote that not me, I was just quoting!


Report •

#28
March 23, 2006 at 15:30:45

It appears we were posting (here) at around the same time so I missed your number 25 post.

"... I object to the snide retort in the other post."

Do you refer to?:
http://www.computing.net/dos/wwwboard/forum/16102.html
=================================================
If he's;
"... removed the partitions with an FDISK, and rewritten the MBR with an FDISK/MBR. I have then created again a primary DOS partition, and formatted the disk."

then I would say the disk is recognized........

=================================================

It's unfortunate that you took it as a "snide retort", it was merely a statement. A statement which happens to be factual though.

It's a good day when you learn something


Report •

#29
March 23, 2006 at 15:52:44

Hi Dan, yeah I was having a little fun with franki. Justin pulled some of our better posts so the remaining ones sometimes didn't make sense if they referred to the missing ones.

I felt that although Nick has posted in the wrong forum there was no real harm in going ahead and trying to fix his problem here. Franki of course felt otherwise.


Report •

#30
March 26, 2006 at 05:47:36

Now now, fellas ,the last thing I want to happen is any of the good people here at computing.net to get into a battle over the posting rules ,and since I started this post apprently in the wrong forum ,I will apoligize and at the same time offer my sincere thanks to everyone that replied and tried to help me out. I consider this place a great asset for people how are newbies to the world of computing and recomend it often to others when they are seeking help .Bless all of you and please lets be thankful this place is here for those of us who love these machines to come and help people out ! Even I through expriencing a certain error message and finding the fix ,have been able to pass that information on to someone else ,with the same problem and help them cotrrect it ! It was a great feeling when the person posted back thanking me for the help !
Take Care to All
Nick

Report •

#31
March 26, 2006 at 12:38:25

No further apologies are necessary. It was a minor mistake. You did a good job in keeping cool about the whole thing. Little arguments like this happen every so often. It keeps things interesting.

It's good you were able to pass along some of what you leaned here.


Report •


Ask Question