Articles

Solved samsung bluray wont connect to netflix

June 19, 2011 at 14:12:17
Specs: Windows 7

My brand new Samsung BD-D5700 is set up with a wireless connection and will connect to the internet. I have tested the wireless connection and have downloaded apps from SmartHub. It will not, however, connect to Netflix, When I try to connect via the app or the button on the remote, I get a message saying that I am not connected to the internet instead of the code I'm supposed to get to activate the bluray. Of course, I checked the connection right away and I was connected, with all of my wireless bars. The main reason I bought this thing was so that I'd no longer have to stream Netflix on my son's Wii! Can anyone help me figure out what is wrong?

See More: samsung bluray wont connect to netflix

Report •


✔ Best Answer
December 22, 2011 at 05:43:28

We just bought a Samsung bluray system yesterday and were having the same problem, I went to Settings > Support > Software Upgrade and updated the firmware and when I tried again it worked! Very happy as that was one of the features we were really excited about. Hope that helps.


#1
June 23, 2011 at 13:47:58

Copyright / protection ... Netflix uses it. The stream cannot be directly recorded. It requires the decoder to view the movies. The steps required to bypass can be found, but its more trouble than it's worth.



Report •

#2
June 23, 2011 at 18:53:13

I'm not trying to record anything, just stream. Samsung says it is not their problem since the internet connection is fine and the other apps work. Netflix says that maybe my router is looking at the streaming as an internet threat that has to be blocked and told me to basically reboot the router. This did not work. I am getting pretty fed up with this. If so many people have Netflix and so many people have Samsung products, you would think the two could work together! Anyone else have this problem and find a fix that worked?

Report •

#3
June 24, 2011 at 07:00:03

I have Netflix. I'm running through a computer, out the video card to video distributor / selector. Kids tried to record a show on stand alone DVD player / recorder. Nothing was recorded. Toasted a disk. Kids were unhappy but they can see that show anytime they want anyway. Not an issue for me.
I'm impressed with the protection Netflix is using. I assume it is in the video like the old VHS tapes were protected. I dunno.
This is probably the same issue you are having. If your Bluray could decode the signal, it could record the show in great quality. I surmise the reason Wii's can stream is that it does not have the ability to record.

Report •

Related Solutions

#4
June 24, 2011 at 12:12:55

I don't understand the reply. I don't want to record anything. My Bluray doesn't even have recording capabilities. I just want to be able to watch Netflix through my Bluray like the Samsung and Netflix websites swear I can. All I am trying to do is stream Netflix to my bluray player and it is not working. All other apps work. I am able to stream Netflix to my computer, which does have recording capabilities, without any issues whatsoever.

Report •

#5
June 24, 2011 at 13:56:04

■Smart Blu-ray Player with Web-Connected Apps – built for your TV that connects to digital content such as movies from Netflix or Blockbuster, TV shows from Hulu Plus, videos from YouTube, music from Pandora, and social updates from Facebook or Twitter

With the Wii, there is an app that has to be downloaded / installed to get netflix to work. Does the manual indicate that for the Samsung player? Maybe a listed web site to get the apps from?


Report •

#6
June 25, 2011 at 08:31:14

Yes, you get the app from Samsung. The app has been downloaded and installed on the player without problem. Could this potentially be a security issue with my DSL gateway trying to block the stream because it thinks it is malicious?

Report •

#7
June 25, 2011 at 09:06:07

I would uninstall the Netflix app, reboot the player, and re install it. Maybe even run a network cable to it just for the app install. If you are having a wireless issue, this will bypass it, but other apps don't have a problem....hhhmmm
The problem seems to be localized to that app. It is not running / displaying as expected.

Has this been addressed by anyone?


Report •

#8
November 13, 2011 at 23:46:23

Having a problem that is sort of the same. I started netflix on my smart blu-ray. Got the code and entered it and played a movie thru the blu-ray samsung netflix app. After watching most of the movie is stop for an hour and then went to restart netflix and the blu-ray said that in needed to perform an update. I clicked okay and then it proceeded to delete the netflix app. It posted a message saying it was deleting the app and now I cant find the app in the selections or by searching for it. I can't seem to make it work now.

Report •

#9
December 11, 2011 at 15:10:47

OMG let me tell you!!! I have been on the phone for 5 hours today with SAMSUNG!
I've been in customer service for over 20 years and NEVER in my LIFE have I been so disrespected, and rudely spoken to my a bunch of ignorant, customer service agents in my life. I am HARDLY racist, however these are nothing more than minimum age people ready from a script. They no nothing about the products, the technology, nothing.
I was with Tier one then Tier Two, then hung up on then called back disconnected again when they get frustrated and have no issues.

I have the DVD 3D Blue Ray Samsung player which will no longer connect to Netflix, saying I have no internet connection. All my other Apps work fine. I have solid internet connection via the bars and am connected.

After 3 hours of that crap, I called netflix again and they indicated that there is a problem with something in the updated firmware which registers a date of Jan 2012 which won't allow you to connect and download because it thinks your accessing pirated programs since the date is wrong. This is how tier 1 at Netflix explained it. He says they have had NUMEROUS calls about this starting yesterday. I demanded to know when this will be remedied but have NO answers and could not get an answer from his upper level persons.

Netflix at LEAST has decent people working for them who apologize and care about the customers.

My biggest frustrations here, as I think it is with many of you is the lack of coordination and communication between two PARTNERED companies leaving the customer in the DUST.

As much as I love my Samsung TV's I will NEVER again buy another one because anytime I have called them for assistance it is the same crap everytime. They treat you like your stupid and when you try to explain ans they don't like that you might know more than them, they hang up on you or put you into a hold which never gets answered. This is just entirely UNACCEPTABLE.

WAKE UP SAMSUNG-- you can't afford to have crappy customer service companies (contracted or employees) working for you in this economy. People will speak out in these types of forums and word travels,.

We spend good money on your products and its time you put our money where your mouth is and stand behind your products, service and partner services. If there is a problem with Netflix and you sell a tv with that APP then partner with them to relay appropriate messages to your customers.

Even Netflix indicated to me that they are working with Samsung to remedy this issue (no fix yet), but that Samsung should have let me know that. Certainly would have saved me hours of MY TIME!


Report •

#10
December 15, 2011 at 18:59:24

I also have a very bad experience with Samsung products as well as their customer service. Here I have put a link to a cnet forum and a reply that I my self put it there. There, you can clearly see how they try to roll the ball towards us.

Forum link:
http://forums.cnet.com/7723-13973_1...

One of my replies(probably the longest):
http://forums.cnet.com/7726-13973_1...

There is nothing we can do(at least in my case), since it is a firmware issue unless they update the Netflix App(or whole firmware). I'll never ever by Samsung again and also I'll let all of my family and friends know about this so that they won't be in this position.

-chhebills



Report •

#11
December 16, 2011 at 09:41:46

This isn't just Samsung, so I believe it is really a Netflix issue. I have an LG tv and am also having the same issues. There is a notice saying that there will be a firmware update on 12/20/11, so hopefully the issue will be resolved then. I haven't been able to stream Netflix on my LG tv for the past few days.

Netflix was not of any help AT ALL. The people were nice but basically were reading from a script. They offered no real solutions and seemed embarrassed that they had not been trained to give real, helpful answers.

Edit for update:

I know you're using different hardware, but maybe this will help you find a way to fix your device? I think it's a permissions issue, that my TV no longer had permission to stream copyright video. So I disconnected the device, signed in again, and it worked. Here's the fix for LG... maybe it will help?

UPDATE: I found a temporary solution to the issue. For the LG 42LE5400, on the remote press "MENU" then go to "Setup" -> "Network" -> "Smart TV Setting" -> "Reset" -> "Deactivate Netflix" choose OK/YES. Then go back into Netflix, it will ask for e-mail and password. Sign in. Then click on a movie and see if you can play it. It took a couple minutes to load, but it worked for us now.


Report •

#12
December 16, 2011 at 12:51:20

In my case, none worked. I did firmware rest as well as all the tricks in the book. Those trouble shooting guides were from Samsung and Netflix as well as from various online resources But none worked. But as you have mentioned, it is actually a licence failure issue.

Right now I am using my Samsung TV to watch Netflix. It doesn't have wireless...but ,it is working. Its user interface not elegant as the one that came with the blu-ray player. But at least it is working. I disabled the automatic firmware download/ update feature in the TV, because I am not sure what Samsung is going to do for the TV next.


Report •

#13
December 16, 2011 at 14:29:24

Okay. I was having the same problem until now!! I had to go to apps and then click on netflix under the video tab and select 'Run' then all is well. Hope this helps!

Report •

#14
December 17, 2011 at 08:04:35

Didn't make a difference.. at least in my case.

Report •

#15
December 17, 2011 at 20:57:54

Well i guess I'm not alone in this I have a newer 3D blue ray D5500 hard wired internet connection and connected to a newer 3D Samsung Smart TV. all was working fine for 4 months that I've had this until I updated to the most recent software 1018.1 update. Have not been able to connect to the interent at all. No more Netflix, nothing at all. where all my computers are online fine and I've rebooted the router just to be sure, and I went to Samsung webiste downloaded the update 1018.1 to a USB drive and tried to reboot to it and MY HUB will not connect to the internet. I think SAMSUNG has a problem here, not netflix or any other apps.
When i check the internet settings and select AUTO find router etc. it's missing numbers in the subnet mask but it won't allow me to correct the one block that needs fixing. it rejects anything i put in manually. Frustrating.

Report •

#16
December 18, 2011 at 06:37:03

Don't think that I work for Samsung(from my previous post, you can clearly see, I am not), because this is the first thing that they ask you to do. Did you try to reset your device? I don't know, in your specific case, how to do that..but If you haven't tried it, you should try that.

If you have enabled DHCP in your router(i.e. every computer in your house gets the LAN IP automatically from the router.), you don't want to fill things like subnet mask. They will be filled automatically.


Report •

#17
December 18, 2011 at 17:06:58

So I've tried everything I could think of. my internet is working fine. tired rebooting the modem and entering in my internet settings from my Mac. nothing seems to be worrking for this TV connection. I'm watching netflix on my laptop and another older TV I have all connected to the internet right now. It has to be something to do with the software update by Samsung. guess I'll try calling them monday.

Report •

#18
December 18, 2011 at 17:15:59

Well I figured out my issues. I unplugged everything at the wall waited 5 minutes plugged it all back in and viola' it's all good. Bizarre.

Report •

#19
December 19, 2011 at 18:28:34

I'm having the same problem!! Anyone know of a fix

Report •

#20
December 22, 2011 at 05:43:28
✔ Best Answer

We just bought a Samsung bluray system yesterday and were having the same problem, I went to Settings > Support > Software Upgrade and updated the firmware and when I tried again it worked! Very happy as that was one of the features we were really excited about. Hope that helps.

Report •

#21
December 23, 2011 at 09:11:59

I too bought my blueray player yesterday, came home excited to start watching netflix and nothing!!! I tried all the things you guys suggested and nothing worked yesterday. Today I woke up and just turned on the blueray player to keep playing with it and as soon as I turned it on it asked me to update and I clicked yes. Went to the Netflix app and it worked perfectly! Samsung fixed it!

Report •

#22
December 25, 2011 at 08:27:00

If your player is working(let's say after a firmware update), can you please let us know the model of the player(eg: BD-D5700)?

Report •

#23
December 25, 2011 at 12:25:05

I just got this blu ray christmas. Netflix wouldn't work...was ticking me off.

CHANGE TO YOUR CORRECT TIMEZONE IN SETTINGS OF BD5700....DONE!

MERRY CHRISTMAS


Report •

#24
December 25, 2011 at 15:19:56

didn't work for me. If you don't mind can you please also let me know the firmware version? Right now I have the newest.

Report •

#25
December 25, 2011 at 15:44:07

Latest version

Report •

#26
December 27, 2011 at 10:22:36

i had the same issue with my smartTV. i shut it off, turned it back on, started netflix, and it told me to go online and enter a code on my netflix account. i did this and it worked great.

Report •

#27
December 27, 2011 at 19:08:31

I have one that doesn't make sense either, but one thing in common is they are all samsung. I have 2 samsung blue ray players and a samsung smart tv. They are all hit or miss on playing a movie. I may have to select 10 different movies before one will play. If I am lucky to get one of the ones I really want to watch, it will load and play just fine. I go to watch another movie and will get the "unable to connect to netflix. Please try again. It looks like its loading and then stops. The Catch is I can load any movie I want on my laptop or desktop PC and plays no problems. I think it has to be a samsung issue, otherwise the PC and laptop should experience the same issue. One of the DVD's is using wireless, seems to work to stream TV shows more often than the movies. Other DVD and TV are hardwired to internet, and hit or miss on loading. Laptop uses wireless and never a issue to load and stream movie or anything. PC is hardwired and never a issue to watch anything.

Report •

#28
December 27, 2011 at 22:00:30

I know that it is a problem of my Samsung BD-5700 player. But it is really hard to prove it. Even if I try to prove it as much as possible Samsung doesn't like to believe it. I have a Samsung LED TV as well as the BR player. Netflix works fine with my TV(Even though I said fine, once in a while it restarts the TV). BR player always gives the message "We can't play this title right now... yada.. yada". Some new BD-5700 hardware works as you can see from previous comments. Probably it is a new hardware revision. I don't know, because I don't have that hardware with me. I am not an complete idiot that can't test such a thing, because I am also an embedded software developer. But I realized that it is totally useless to complain to Samsung and unfortunately I gave up with one thing in my mind. "Never ever Samsung brand again to my house"

Report •

#29
December 28, 2011 at 11:09:05

Ok. . I was going to blame samsung but i don't think it is their problem, per se....

my bet is that the real issue is in DNS lookup being blocked by my ISP.

What I did is used static IP settings for the samsung product in question and pointed its DNS 8.8.8.8

My router is 192.168.2.1
DHCP range is 192.168.2.200 through 192.168.2.225
subnet mask is 255.255.255.0

so I set my bluray up as follows:

ip address: 192.168.2.199
subnet mask: 255.255.255.0
gateway: 192.168.2.1
DNS: 8.8.8.8

this worked like a charm!


Report •

#30
December 28, 2011 at 14:06:38

@bas_I_am
I really doubted that it is going to work in my case. As I have mentioned above what I have in my player is a licence issue. It is unofficially confirmed by Netflix. One of their agent said that the error message they received is "Acquire Licence Failure". I don't have any network connection problem in my player. But I tried your solution and didn't work. Thanks anyway.

Report •

#31
December 28, 2011 at 21:37:02

My problem is a bit different from what I've read here. Two weeks ago, the Netflix App on my relatively new Samsung Smart TV was automatically de-installed and re-installed. I opened up Netfix and the UI was totally hosed. The first thing I noticed was the connection/load splash screen, rather than covering the entire viewing space, now had grey borders top and bottom. Once into the app, the tiles were huge; there was no way to traverse to menus. I could, however, select and play movies.

I went the "call Samsung call Netflix call Samsung" route. Someone at Samsung told me they had been receiving a lot of calls on this. Netflix only acknowledged the issue when I called back a few days later and informed them I was cancelling. I was told the app was no longer compatible with Samsung Smart TVs, a result of a push to allow compatibility for other platforms. I find this hard to believe because you'd think this would be all over the net. It isn't.

Rather than getting an expected customer retention spiel, I got a "Sorry ,See Ya."

In all the back and forth, per Netflix, I deactivated and reactivaed my account to no avail. Per Samsung, I did an app reset. To no avail.

I have no problems with any other apps and no other issues with the set.

Anyone else having a similar issue?

TIA


Report •

#32
January 1, 2012 at 22:00:47

Setting the timezone worked for me. Weird! Thanks so much for posting.

Report •

#33
January 5, 2012 at 08:35:40

I've had an issue with my Samsung player and netflix for a week- i can play netflix on my roku and my laptop, but not the BD. I can see changes I've made to my netflix withthe BD, but when i go to play anything it tells me to try again later. I've tried everythign possible and talked to people at bothNetflix and samsung. Both groups of people were pretty good to talk to and were helpful - Netflix insisted it was samsung and samsung insisted it was netflix. I sided with netflix overall because i've had other issues playing netflix with the BD. After the last conversation with Samsung i insisted I talk with a supervisor - he talked with me for a few minutes, put me on hold, then came back and told me they are aware of some issues with the BD-5700 and that they are working on a fix right now! They said it should be rolled out in 2 weeks or so. Why couldn't samsung admit this at the begining. I'm going to go back to my Roku - it works much better for me and isn't full of this BS!

Report •

#34
January 17, 2012 at 08:30:12

I've been advised, through my research of this same issue that we all need to contact the State Attorney General's office, division of Consumer Affairs and file a complaint.

http://www.nj.gov/oag/ca/ocp/ocpfor...

Samsung is headquartered in Ridgefield, NJ. This is the only way to wake them up to their fraudulent practices and have them resolve this issue.

I've started a petition to stop Samsung's abuse of the consumer. Join me in ending this known fraud.

http://www.change.org/petitions/sam...


Report •

#35
January 18, 2012 at 18:47:01

go into settings, change to appropriate time zone, turn off and back on and it will ask for your activation code!

Report •

#36
January 20, 2012 at 18:03:44

I apologize in advance but this statement is just asinine. To say that Netflix will not work through a blue ray player that partnered with them to have to product work due to them fearing recording is truly stupid. First off a standard blue ray player is just that a player, not a recorder. Second, if this were the case, then you would not be able to stream to a computer to begin with as it's much easier to capture and record stream data from a computer.

On a side note, this does appear to be an issue directly with Netflix. I am also having this trouble and seeing how everything else works, but Netflix it's something to do with their widget. My network was built with me, no DHCP, I have no router. I'm running a home built computer with two network cards and using one as my internal network's interface, the first is the wan interface, so there is no firewall. Any internal traffic is automatically pumped to the outside world. Only traffic coming in that is allowed must be initiated internally first.


Report •

#37
January 25, 2012 at 01:35:42

I have exactly the same problem connecting to Netflix with my Samsunf BD-D6500 blu-ray. I am hard wired to the Internet. I get the message that I am not connected to the Internet. Netflix told me it was a Samsung problem and Samsung says it is a problem for Netflix. I am bringing back the unit and will try Panasonic.

Report •

#38
January 25, 2012 at 11:15:27

I had the same problem with Samsung Blu Ray BD-D5700. We just bought ours on Jan 22, 2012 and tried connecting to Netflix and was getting the same error "Not Connected to the Internet". So we followed several steps:

1. Updated the firmware to the latest version (Release Dec 20, 2011). Tried to connect to Netflix and FAILED

2. Turned off Samsung Blu Ray player for 10 mins and turned back on and tried to connect to Netflix again and FAILED.

3. Turned off Samsung Blu Ray player and unplugged for 10 mins, turned back on and tried to connect to Netflix again and FAILED.

4. LASTLY, turned off Samsung Blu Ray player and unplugged for 2 hrs! Turned back on and tried to connect to Netflix again and SUCCESS!!! Seriously, I have no idea why it worked but it did.



Report •

#39
January 26, 2012 at 08:18:00

Hope this one may help. Turn off the router/modem uplug it from the power source. Now, go to the setting of your blu-ray(setting>system>time zone) and choose the correct time zone on your location. Turn on your router and try to access NETFLIX again.

Report •

#40
January 29, 2012 at 17:37:03

Bought a Samsung BD-D5700 today. Tried all the "fixes" posted in this forum, still no Netflix. I am not messing with customer service, I'll just return it tomorrow. I should have known when I saw "resealed boxes" in the pile.

Report •

#41
January 29, 2012 at 17:39:45

I called Netflix and they informed me that there is a known problem with the Samsung Blu-Ray DVD Model BD-D5700 when connecting to Netflix. According to the customer service representative Samsung and Netflix are working to correct the issue.

Report •

#42
January 29, 2012 at 17:46:05

It's unfortunate that Netflix does not work on model DB-D5700 because all the other features are awesome.

I also happen to have a Samsung Blu Ray dvd model # BD-D5100. Netflix works on this one but there is no 'Smart Hub' feature and it only provides the 'wired' option to connect to the internet.


Report •

#43
January 29, 2012 at 21:19:49

Well, I just wasted 3 hours of my life trying to get netflix to work on my brand new BD-D5700. I did everything listed here and I am now... GIVING UP! I will be returning this at the first chance I get. See ya tomorrow, BestBuy!

**********Update**********
I thought I would give it one more try today before returning it. Now, for no apparent reason, it is working! All it did was sit overnight, plugged in and off. Whatever... I might keep it.


Report •

#44
January 31, 2012 at 07:24:38

I just bought the Samsung D5700 last night and had the same issue. After reading several forums, I tried the following and it worked...go to SETTINGS, scroll down to SYSTEMS, choose TTIME ZONE. After pressing ENTER you will be given the option to change to your time zone. Once I changed it based on my location, Netflix started working. I hope this fix helps someone else.

Report •

#45
January 31, 2012 at 10:37:03

Netflix told me the same. I tried everything on this forum and am still not able to view movies. I get as far as selecting a movie, but when I play it I get the following message: "We're having trouble playing this title right now. Please try back later or pick a different title." I can view Netflix on any other device but this Samsung Blue Ray DVD player (BD-D5700-ZA, SOFTWARE VERSION BSP-D5700ZA-1022.0)

Report •

#46
February 1, 2012 at 04:23:02

Yep same problem here with my 5700. I bought it a couple of weeks before Christmas and up until a couple of days ago it was working fine with Netflix. Then for no apparent reason it stopped working. I can connect to Netflix fine and scroll through the movies/shows fine, but when I try to play anything it gives me the, "this title is not available right now..." It does that for everything. I've tried all the fixes listed here including the timezone thing and seeing if there were more recent firmware downloads available. Nothing.
I've also called Netflix and they told me as well that several models of Samsung blu ray players have known problems (5500, 5700, and something else). They said Samsung was trying to fix it but they had no idea how long it would take.
It just seems odd that it worked just fine for almost 2 months then one morning it doesn't work anymore. Can still get it through the wii in the kids' room but thats it right now.

Report •

#47
February 1, 2012 at 14:41:02

With a brand new Sansumg BD-6500; latest firmware; apps; correct time zone. Other network apps are functional, Netflix reports "No connection to the Internet"

Given that I've had repeated issues with netflix on other Samsung devices, which also stream Amazon content flawlessy, I am inclined to point the big finger at Netflix and their seeming inability to get client side apps functioning properly.

How they managed to ship and app that is broken on a broad class of devices is a mystery, unless they're simply incompetent, which seems more likely as the rate of breakage increases over time.


Report •

#48
February 2, 2012 at 18:57:14

Samsung BD-D5700. We have had this bluray since last May. We got it just for Netflix. There were some rebuffering issues at first, but that cleared up ok and everything was fine. And then ... on January 11, at 9:30ish pm, we went to watch and got the Can't play this title right now... For 3 weeks, I was sent from verizon to netflix to samsung. THREE WEEKS! It's the wireless, it's the bluray, it's netflix. All along netflix and samsung knew this was an issue due to incompatible updates and jerked me around for THREE WEEKS.I've reset netflix. I've reset my router and moved it around. I've plugged and unplugged. I've held the stop button on the bluray for 10 seconds (more) and reset the player. I've checked my time zone. Finally, last Saturday, Corey at netflix admitted they knew there was a problem, gave me 20% (not kidding) off my next month's bill, and said hang in there, they will fix this problem at some point. I called best buy and they said the player is still under warranty, and this function is not working due to no fault of my own, so they will send it back to samsung as a manufacturer's defect. It is not netflix. It is not samsung. It is both of them not working together and giving some piss-poor awful customer service. Did I mention that for THREE WEEKS they jerked me around? Such a shame.

Report •

#49
February 2, 2012 at 20:11:39

Wow - weirdest thing I've ever seen. Was getting the "No Internet Connection" message. Found this forum. No firmware updates available. Had already set my time zone but Netflix still wasn't working.

- Turned off Blu-Ray player
- Unplugged it
- Waited two minutes
- Went back to Time Zone and didn't change anything, just hit save again
- Went back to Netflix and it worked


Report •

#50
February 6, 2012 at 22:57:50

I just bought mine today and as soon as I got it connected it said not connected to the internet and it "D" settings/properties I get the Netflix ESN not support [X]

Report •

#51
February 9, 2012 at 08:49:11

jb419, any luck getting it to work? I am seeing the same thing on my "D" settings/properties as you. Is there a fix for this?

Report •

#52
February 10, 2012 at 09:44:13

I just want to let everyone know, that if you reset your blu ray, to go back into the settings again to set the time and the time zone. Everytime you reset it, it goes back to 00. Netflix requires a time and time zone to be correct to let you access
their content. If that does not work, also disconnecting all cables for two minutes, including power and internet cables so that the ip address refreshes.

Let me know if it work!!


Report •

#53
February 13, 2012 at 15:21:34

Andy1ram, no it doesn't work. I've tried all of that and then some many times in the last couple of weeks. When I get my tax return back I'm buying a new (non samsung) blu ray and tossing this one in the trash.

Report •

#54
February 13, 2012 at 22:46:08

so I have a BD-d5700 and everytime I try to play a netflix movie or Vudu movie it rebuffing and it does it constantly, so I took my player back to bestbuy the guy says you need a new router so I updated to the most expensive one and I just switched internet companies too so I could have cable internet and my speedtests are hitting about 24mbps wirelessly and I am still having trouble with netflix and vudu it rebuffs or it will give me a message on netflix only (can not connet to netflix at this time please visti www.netflix.com/helptv to find a solution or something to that affect) I am pissed off, I have called netflix samsung and comcast and each one blames the other. I don't think it is my internet or my router because I can stream netflix on my xbox and PS3 and computers and kindle fires all day long with no problem, so that must mean it is the player, im going to take it back tomorrow and spend a few more dollars and just get a sony. Pisses me off because the apps and stuff on samsungs hub are the best I have seen, to bad the things wireless capabilities suck@$$! I even hardwired the damn thing and the picture quality still was subpar and it still rebuffed I just don't get it and I am done wasting money and time driving to bestbuy and on the phone trying to explain my issue and the things I have already done to try and resolve it. I love when they say well just power cycle your router and modem, like no crap, like I haven't tried that a million times already. So I say if you have a problem like me return this player for another brand while you still can!

Report •

#55
February 18, 2012 at 08:24:28

I had all the same problems as dicussed in this forum with my new Sansumg BD-6500 Blu Ray player, I tried all the solutions offered, I would get the Netflix to start streaming but after I would stop watching Netflix and changed to another program and tried to come back to reconnect all the problems started over, the cost of frustrastion is unhealthy. My solution I purchased a Roku from Amazon and never more had Netflix connection problems, this is not a plug for Roku only a solution I decided on , and for the $99. it was well worth it. I rarely us the Samsung any more onl for the Blu Ray DVD's. I now have purchased 3 more Roku's and never a connection problem it's always there when I want to watch Netflix.

Report •

#56
February 18, 2012 at 08:38:27

bd-c-5500t Samsung works fine with netflix however does not show all titles
available that show up on the menu of my computer.
The hard drive seems to be to small for full sampling of titles

bb


Report •

#57
February 19, 2012 at 18:50:11

did you ever get it working? I have a friend that bought a samsung blu ray player because that was one of the features it said it had. I got it connected to the internet via wireless. Other apps work but when I tried to connect it to netflix it is saying it is not connected to the internet.Called Samsung, they gave me no help. Called netflix they gave me no help except instructions on how to reboot the router.

Report •

#58
February 23, 2012 at 20:37:57

Today i purchase a bd-c6500 mainly for the wireless and the netflix and immediatly had problems. the wireless connected and the other applications worked but not net flix. i reset the timezone, updated the software and it still did not work. the message it gave me was "no internet connection" i checked the connection mutiple times it was always good. finally i went into the samsung app in the hub and found the netflix app under video and started netflix from there, it worked and i have been able to enjoy the app ever since .

Report •

#59
February 25, 2012 at 19:23:36

password, check it..re-do from start, if not call vendor

Report •

#60
February 27, 2012 at 07:32:22

For those still having a problem. Look at the encryption that is being used by the Wi-fi. I was trying to get this to work for a family member and his Wi-fi was using WPA. I changed the encryption to WEP128 and Netflix started working.

Report •

#61
February 27, 2012 at 19:38:18

I just bought the Samsung BD-D5700 and was having similar issues. I tried a couple of the things on this forum, but the one thing that made my Netflix app to finally work was fixing the time zone, turning off the dvd for a good hour and then going back in and trying it again. Now it works just fine. I have gotten the message on a couple of movies that 'Can't play this title right now'. But was able to select others, not sure what that is all about. Good luck to the rest of you and I hope my keeps working.

Report •

#62
February 28, 2012 at 11:45:27

I just purchased the Samsung smart blu-ray player BD-D5700 about 2 weeks ago with the intent of watching Netflix on it.  Thought it was time to let the kids take back over their WII. :-)  Unfortunately, the BD-D5700 is great at everything except streaming Netflix!!!

When trying to watch a movie on Netflix, the movie freezes up and starts to rebuffer every 2-3 mins.........so frustrating!!!!!  I tried all of the suggested trouble shooting tips.  I have spent hours on the phone with Samsung customer service and I also performed all of their suggested tips with no success.   My Internet speed is great and all of my other wi-fi devices continue to stream Netflix with no problems.  

Even more irritating is the terrible customer service.  I have lost all respect for Samsung products because of the lack of respect I received during a recent phone call!  These people act like they don't know that a problem exists with their product's ability to properly stream Netflix .........instead, they are asking me to mail my device in to them to see if they can "repair" the problem..... Yeah right !!   I just want my money back so I can purchase a non-Samsung smart blu-ray player!

After surfing the net today, I see that this Netflix problem is not new to Samsung........it appears they have known about this issue for quite some time , yet they are still selling these devices and advertising them with the ability to stream Netflix . ....that is so deceptive!  But it really upset me when the customer service guy played dumb today and said that I need to send my 2week old blu-ray player in for a service check to see why it's not streaming Netflix  .........Really????  Are they REALLY going to play the dumb card with me?

I am disgusted with their lack of quality assurance!!!


Report •

#63
February 28, 2012 at 22:55:54

====HERE'S THE ANSWER FOR EVERYONE WITH A SAMSUNG BD-D5700====

Don't know if this is a repeat of others answers but follow this to the letter and your nightmare will be over!!!

Open the box, connect the BD player to TV, turn on and do the System Firmware update first, next do the Smart HUB Apps software update. Next try to connect to Netflix...it will surely fail! ----> after the failure, turn off the BD with remote, then "UNPLUG" the BD from the wall and wait 2 minutes. Plug the BD back in, power on and let it boot up - go to the Smart HUB and click on the Netflix icon - a new screen will popup asking you if you are a Netflix member, select "Yes" - then another screen will popup with a 5 digit code, write down that code and leave the BD player and TV right there - "DO NOT TURN OFF" or move from that last code screen, now go to your computer and logon to Netflix and click on the link in the top right corner "Your Account & Help" - scroll down and click on "Activate a Device" - then enter the five digit code and click "Activate" - wait approx. 2-5 minutes (depending on your internet speed) and the BD and your online account will automatically "sync" and update your device. Go to your TV and BINGO! Nightmare over!

Should work with other Samsung Models also...

All I can say is, "what a MF journey that was!" Never had this problem with my Sony BD....

Hope this helps...
rain


Report •

#64
March 1, 2012 at 06:59:40

I feel for all those going thru this, I just had similar experiences. My advice, as I am going to do, is cancel netflix and join Hulu, who has the same movies and shows and actually works for the same price per month as netflix

Report •

#65
March 1, 2012 at 09:51:43

I have tried absolutely every solution proposed here, and others... Nothing worked. Updated to the latest firmware again today: 1023.0 Feb 10, 2012 ... Still doesn't work. Reset and rebooted and reinstalled... It's hosed. Netflix doesn't work at all...

Report •

#66
March 2, 2012 at 14:01:55

Hope this one could help. On your palyer Go to smarthub, while on the smarthub screen press the blue D button on the remote control and that would access the setting of smarthub. Now, under the setting of smarthub select properties and then under properties select details. Check the following details:

Smarthub Version: X.XXX-X.XXX.XXX
Netflix ESN: NOT SUPPORTED

If the Netflix ESN is "not supported" the unit needs to be repaired or you can call Netflix people to activate and reactivate(reregister) your netflix ESN.


Report •

#67
March 4, 2012 at 08:27:59

I tried every suggestion on this thread and then minutes before I was going to return the unit to the store I tried one more thing which worked for me.
Try changing the Time Zone to something besides the one you are in. I am in Central TZ (with Cox) but as soon as I changed the TZ to Eastern the ESN setting looked good and I was able to connect to Netflix.
I believe their is no one vendor at fault, but having all the Samsung, Netflix, and your ISP settings align is the key. In any case I am a happy camper and I enjoy the iPhone remote control app as a plus.

Report •

#68
March 4, 2012 at 20:59:53

got rid of two samsugns and got rokus, now everything works great! I did not know how great netflix really was untill now. All is wireless. what a relief after all the hours trying to get samsung to work right! the rokus are only half the price of samsungs.

Report •

#69
March 5, 2012 at 11:28:51

You are lucky! I can't get mine to the internet and Samsung says I have to downgrade my security settings! If my Wii (downstairs) is streaming fine, should't the blu ray?

Report •

#70
March 5, 2012 at 13:51:53

I also have the Samsung Bluray player, keeps rebuffering on Netflix. Also have problems with a Samsung Smart TV and Netflix, will not play sound through my sound system and the picture quality is poor. The router shows the connection is fine but can't get any help from Samsung or Netflix. They don't know there is a problem and keep suggesting the same old standard fixes. I have a Samsung TV, Bluray Player, Tablet and Phone and have found their support is almost useless.

Report •

#71
March 6, 2012 at 14:57:17

I have a new Samsung Blu Ray player and I tried all one day to connect to Netflix in the bedroom. I unplugged the unit, hooked up to the TV "Wired", turned it on and then I got the code to activate Netflix. Then I switched back to "Wireless" and it is wonderful! It works!!

Report •

#72
March 6, 2012 at 21:40:21

MY SAMSUNG 3D BLURAY WONT WORK for netflix so went and changed player to proper time zone it works great now SETTINGS TO SYSTEMS TO TIME ZONE FOR MY AREA CHANGE TO DEFAULT PUSHED YES got code BE SURE TO LEAVE PLAYER ON put PUT CODE in netflix on computer to activate item came right on

Report •

#73
March 7, 2012 at 07:35:08

THIS RESOLVED MY NetFlix ISSUES!!!

First here's my equipment info:
UN55D6000SFXZA
Wired internet connection

I have been using the NetFlix app since buying my Samsung in Feb 2012 without error. Yesterday I had an update pushed but never got to see any details (version/date). That's when my NetFlix stopped.

I would get just a black screen... no messages, no warnings. The system would stop functioning for a couple of min. Then would return to regular screen (Wii or Satellite).

I am somewhat skilled at troubleshooting so I began the steps all with no success. I switched to the Wii and NetFlix worked fine. I deduced that the issue is with the NetFlix app. Until I started reading all of these posts.

I returned to my Samsung and double checked all of my settings... Network connection, Date/Time group, user name and passwords... Then I saw it!

SMART HUB RESET! Did it... all problems resolved.

Good luck!


Report •

#74
March 7, 2012 at 13:58:13

Bought my Samsung BD-D6500 last Wednesday. Netflix had a "Not connected to internet" error.

1. Did research on the web. Set the time zone, reset the device. No dice.
2. Called Samsung. Samsung rep asked me to
A) Check the timezone on my router (which was wrong)
B) Tell the router not to use an NTP server
3. Reset device again. No dice.
4. Called Netflix, even though I was certain it was the Blu-Ray's fault. Netflix rep asked me to go to the error screen and put in this "cheat code":
UP UP DOWN DOWN LEFT RIGHT LEFT RIGHT UP UP UP UP
this revealed the version number of both the firmware and the Netflix app.
5. Called Samsung to report version numbers. Samsung suggested I do a firmware update (was at 1016 instead of 1023). Said they would send instructions; they didn't, but I found them anyway.
6. The first update did not work--(RUT file), but the second update had a big disc image folder with several files, and that one loaded just fine.
7. Still no Netflix. Just to be certain, I watched all of the free movie on Hulu Plus to be certain nothing was screwy on my end.
8. Called Samsung again today. Tech suggested another hard reset of the device.
9. I was skeptical, but I did it, and boom! Netflix. "Are you a member" and the activation code. Activated via my desktop, and now I'm streaming just fine.

I'm keeping my fingers crossed that future firmware doesn't hose me, but I've got the current firmware saved to my desktop just in case.


Report •

#75
March 14, 2012 at 13:07:16

I'm having the same problem with Samsung (in my case, to connect with Blockbuster) AND Samsung's supposed customer service is totally inadequate. I have a first rate in-home entertainment system and never again will I buy Samsung

Report •

#76
March 16, 2012 at 11:47:21

GO TO TOOLS AND UPDATE THE DRIVER THROUGH SAMSUNG'S UPDATE THROUGH YOUR DEVICE. ONCE IT DOWNLOADS IT NEW UPDATES IT WILL WORK FINE. I HAD TO DO THIS, AND FOR 50% OF THE DEVICES OUT THERE YOU HAVE TO DO THIS BECAUSE THE DRIVERS ARE OLD. I KNOW STUPID ISN'T IT?

Report •

#77
March 21, 2012 at 14:21:05

I had a client with a BDD6500 that was not connecting to the internet after working fine for several hours. Under the Network settings it showed that it was not getting IP and there was no connection. The unit was up to date as of 3-20-2012 on its firmware updates. After reading this forum, I started by disconnecting the router and bluray from power for approximately 5 minutes. After firing it back up and checking network status, Netflix and Pandora are working fine.

Report •

#78
March 24, 2012 at 00:11:24

Have a BD-D5700 just manually updated to March 22 version 1025 and my teal screen and wireless rebuffering in Netflix both seem to be fixed finally!

Report •

#79
March 24, 2012 at 15:52:14

UPDATE FIRMWARE TO VER 001025 AND IT WILL FIX YOUR NETFLIX REBUFFERING, NOT CONNECTED TO THE INTERNET, BLUE SCREEN, ETC...

-NAGINI_2011


Report •

#80
April 2, 2012 at 22:27:58

Honestly, I think all these upgrades are causing the problem. However, thank you who says choose the version 001025 it worked. My screen is no longer teal blue with picture and not just sound. Thank you and goodnight. Its funny how the last entry Solved my problem after reading top to bottom.

Report •

#81
April 13, 2012 at 18:39:05

Getting the "We're unable to connect you to Netflix.." message. Latest firmware installed - 001025. This is maddening, because there's literally nothing you can do with the app at this point. All you do is Try Again, which does nothing, or Exit. I've unplugged the router, turned off the player, and tried it over and over again - same results. So infuriating. Yes I changed my time zone to my time zone. I hard reset the Smart Hub. Nothing. Any other suggestions?

Report •

#82
April 16, 2012 at 12:18:19

We bought a new Samsung blu ray player a couple months ago, primarily to use for Netflix. Worked fine until this past weekend ... kept getting the error message that it wasn't able to connect to Netflix, yada yada ... the folks at Netflix did everything they could but nothing worked, it's a Samsung software upgrade problem. We remedied the problem by resetting the blu ray player: Make sure there's no disc in tray, then push and hold the "stop" button for five full seconds. The player will reset and you have to go through the setup process again, but it cleared up the problem!!!

Report •

#83
April 16, 2012 at 18:02:43

Set the correct time zone and it should work. I updated the device first. Had all the same problems as listed above.

Report •

#84
April 16, 2012 at 18:55:23

I understand you and am having the same problem. Have this same Samsung player and Netflix. It actually works when viewing full HD cartoons and SD quality older kids videos like Barney - I assume because the bitrate needed for animation and SD videos is less than a full motion HD video.

But when I try to watch Mad Men over Netflix it will start the video then immediately go into a "rebuffering" mode. The first time this happened I thought it was because I was home during a day off and network traffic was much more during the day. Yet I found this not to be the case since not many people in my neighborhood have Comcast internet, and I was getting well over 20mbps on my connection. A Netflix HD video in 720p requires 3-4mbps and I am getting well over that.

Back to my problem...above and beyond the rebuffering issue, it will actually pop up a window during a movie and say "You Are No Longer Connected to Netflix. Contact Netflix.com/SomeWebsite For More"

It is now April 2012. Anyone get a fix for this yet???


Report •

#85
April 17, 2012 at 21:41:08

Suggestion in post #29, like he said, worked like a charm. Thank you so much!!!!

Report •

#86
April 19, 2012 at 12:51:29

yeah in situations like that its the actual app on the blue ray player what you have to do is diactivate the device from your netflix account you can call them and they"ll do that for you the you have to call samsung so they can refresh the app or do a manual reset

Report •

#87
April 19, 2012 at 13:55:42

yeah i had the same problem just on the netflix side make sure that you deactivate the device you can call them or do it on line through the account that will refresh the app well there getting that issue resolved

Report •

#88
April 22, 2012 at 17:09:47

BD-D5700-ZA never connects. It is not just neflix, it is the same Pandora, anything .Network interference has occurred. I hate this unit . Just buy a WII. Samsung, not only did not answer me, but they keep emailing me ads for new products. I have never been so furious about a piece of equipment.I have to keep it because my daughter gave it to me or it would now be part of a PC Richards employee's anatomy.

Report •

#89
April 24, 2012 at 08:56:25

wow post 29 really helped with the dns. i kept the same ip the auto detect gave me and just changed the dns to 8.8.8.8 and all apps giving me problems started working. Sadly the streaming turned out to be super slow, but at least its something different than the no internet issues. im using the bd-e5900

Report •

#90
April 25, 2012 at 12:53:58

I have been unable to play netflix movies for 2 months. I get the run a round with Samsung support. The problem I'm having is I can connect to netflix but when I pick out the movie I want the message I get is" unable to play this title right now try back later or pick another selection". This is the case with all of the selections. My model is bd-d5500 I've tried everything reset the unit tried just hooking it up to the modem from my isp.

Report •

#91
April 26, 2012 at 13:51:24

I had the same problem as #90. I ended up getting a RMA from samsung and sent in the device for repairs. Unit is back and I am able to use Netflix without issue.

Report •

#92
April 26, 2012 at 14:35:55

I have the same problem with the same samsung model I just purchased. Anyone find a fix yet?

Report •

#93
April 27, 2012 at 16:31:20

TRY THIS FOR FIX: On Samsung device as noted you can not 'set time' only 'time zone'... Try using the method below but if your time-zone will not work, then try a time-zone to your immediate left or right.

Samsung tech support sent these 3 items...
· Power off player for one minute
· Power on the player and set the time zone
· Launch Netflix and error should no longer appear

For example I needed to set time at GMT-5 for EST, but worked with GMT-4 (And I do not live in ocean) Hopefully this helps


Report •

#94
May 9, 2012 at 17:17:01

Had all the problems described above and was about to sent player back to Amazon. Set time zone correctly, went to hub, the apps and then redownloaded Netflix and Blockbuster, now everything is working. Accessing the movies through the apps window on the hub seems to solve all the problems.

Report •

#95
May 13, 2012 at 18:26:31

Thank you #35 Your Suggestion worked for me!

Report •

#96
May 14, 2012 at 00:19:12

how do you choose what you update??

Report •

#97
May 16, 2012 at 19:36:57

We've been having this problem for a while now, too (the only reason I haven't gone ballistic is because we have two other ways to get Netflix, but it would be nice to get it in our family room). After the run-around from Netflix and Samsung, I finally got out of Samsung that somehow the Netflix EIN got changed, and that was causing the problem. You can see the Netflix EIN by going to Internet (Smart Hub)> press the small blue "D" button>Properties>Detail. When I mentioned the Netflix ESN to the tech I had on the phone, they knew it was the incorrect ESN for my model (D5700). If the second alpha-numeric set is D670 (for the D5700 blu-ray), you have the same problem. That set of numbers/letters should be D570.

I've looked online for a fix, but no luck so far. Anybody know how to get that changed back to the original Netflix ESN?

I've been told that they escalated my issue, but the level 2 techs only call during the day, when nobody is home. If there are any Samsung techs reading this, I have two questions for you: 1) How did this happen? and (more importantly) 2) How do I fix it?

P.S.: We've tried all of the fixes suggested in this thread several times, but I'm not going to keep resetting my blu-ray player when I know what the issue is.

P.P.S.: I'm seriously considering taking #34's advice and contacting the AG's office. Either that, or figure out how to initiate a class-action suit against Samsung. We really need to hold Samsung's feet to the fire on this. This is a known problem and they're not doing anything (at least not enough!) to get it fixed.


Report •


Ask Question