Articles

laptop cpu swap question

Compaq Presario 700 (x2
November 5, 2006 at 05:51:21
Specs: XP, 900/256

I have a compaq Presario 700 laptop which the screen was damaged. It consist's of a AMD duron cpu, 256mb ram, 20 gig hard drive.

I purchased another presario 700 laptop for PARTS on ebay and did a complete LCD swap. Now the laptop is working fine again.

Now on to the cpu question.

Both Laptops are identical looking from outside and both are SERIES CM2130. Both are Compaq Presario 700's. Everything seems to be the exact same besides someone robbed the ram and hard drive with exception of the cpu.

The parts laptop came with a 1.3ghz Athlon cpu. Now to let everyone know I first removed the 1.3 ghz cpu and tested it in a known working desktop computer and it booted up fine detecting it as a Mobile cpu. I ran the OS for about a half hour or so playing around checkin email etc. Ah a bonus cpu upgrade I think :).

Knowing that the cpu is good I procede to disassemble the 900mhz presario and do a CPU swap. Upon completion of cpu swapping I go to boot up the working laptop and it the laptop acts like it's going to boot up normal only to freeze at the windows splash screen. After rebooting a couple times I made it to the logon screen but never into windows. I swap back to the 900mhz and all is back to normal.

I know how to properly install a cpu in most desktops but i'm kinda stumped here on this laptop. Anyone know why I can't swap cpu's on identical laptops? Is there some kind of setting i'm missing?

ASUS A7V8X
Athlon XP 2700+ @ 2.17ghz
1GB DDR 2700
nVidia 128mb FX 5200
WD 80gb SE
NEC ND-3500AG DVD R/RW


See More: laptop cpu swap question

Report •


#1
November 5, 2006 at 07:50:25

It seems like the presario 700 notebook series support upto a 1400Mhz Athlon from this ebay seller...

http://cgi.ebay.com/Compaq-Presario...

So I don't see a problem with compatbility of your 1300Mhz Athlon. My suspection would be to make sure that the athlon CPU is not overheating and causing freeze during windows splash screen.


TMP-Man

Asus P5P800-SE
P4 506 @ 4009Mhz 1.3625v
Thermaltake CLP0024 w/ 1700RPM 92MM AS5
2GB OCZ 2-3-2-5 DDR400 PAT
120GB/300GB 7200RPM HD
Leadtek 7600GT AGP 590/1600 VF700 ALCU AS5


Report •

#2
November 5, 2006 at 08:13:55

Well i'm pretty sure it wasn't overheating as the heatsink plates in both laptops look to be the same and when I put the 900 back in I had no problems. Otherwise I really don't know how to tell.

ASUS A7V8X
Athlon XP 2700+ @ 2.17ghz
1GB DDR 2700
nVidia 128mb FX 5200
WD 80gb SE
NEC ND-3500AG DVD R/RW


Report •

#3
November 5, 2006 at 11:02:26

Even though both Presario 700 notebooks are identical looking from outside and both are SERIES CM2130. The fact that they both have two dissimilar CPUs is a clue that they are not really the same animal on the inside.

I suspect the motherboard in the two aren't the same and that is why you are having a hard time just swapping out the CPUs. If the Athlon 1.3GHz is in fact a 1.33GHz version (133 x 10) and your motherboard does not support the 133MHz, then it's no surprise the Duron 900 (100 x 9) works and the 1.3GHz Athlon doesn't.



Report •

Related Solutions

#4
November 6, 2006 at 13:49:40

Use the cpu in the parts motherboard and move all your drives and memory(and lcd again) to the parts machine. First check the parts machine with an external monitor to make sure it boots.

Report •

#5
November 8, 2006 at 14:14:19

Parts machine is just that, parts. No boot no nothin. It didn't even come with ram, when ya plug in a power supply don't even light up.

Tell ya I think the 1.3 runs at 100 x 13 but i'd have to swap it to the desktop again.

I just picked me up a walmart special AMD 3300+ compaq laptop with win mce. hope it last's as long or longer then some of those older compaqs...

ASUS A7V8X
Athlon XP 2700+ @ 2.17ghz
1GB DDR 2700
nVidia 128mb FX 5200
WD 80gb SE
NEC ND-3500AG DVD R/RW


Report •

#6
November 9, 2006 at 09:41:50

"Tell ya I think the 1.3 runs at 100 x 13 but i'd have to swap it to the desktop again."

Not if you post the full markings on the CPU ;-)


Report •

#7
November 10, 2006 at 14:43:57

Guess I was wrong. The computer I tried the mobile cpu has the 1.3ghz in it. The cpu from the laptop is 1.2ghz.

AMD Athlon
AHM1200AHQ3B
AGOIA 0219RPCW
98696840101

1999 AMD

Guess I should have took it out and checked before posting.

Still I know it worked in the desktop as it came up as mobile cpu.

I'm gonna swap laptop cpu's again just to make sure I didn't try to put the 1.3ghz in by mistake.


ASUS A7V8X
Athlon XP 2700+ @ 2.17ghz
1GB DDR 2700
nVidia 128mb FX 5200
WD 80gb SE
NEC ND-3500AG DVD R/RW


Report •


Ask Question